Talk:MPlayer CE

From WiiBrew
Jump to: navigation, search

Encoding Video For MPlayer CE

Has anyone tried to figure the optimum settings for h.264? XVID seems to run a lot smoother.

h.264 is capable of comparatively very high compression meaning it takes a lot more raw processing power to decode. The Wii's CPU is somewhere around 700 mhz (not very fast at all by today's standards). Therefore, I believe to find the optimal settings in this case you would have to try and reduce the level of compression used during the encoding process. -Flark 17:21, 25 February 2009 (UTC)
I find that H264 videos 640 pixels wide must have in-loop deblocking and CABAC encoding disabled for them to playback smoothly on the Wii (if you are using x264: --nf --no-cabac). The Wii is like the original XBox running XBMC in this respect. It reduces quality but it's still better than XVID at similar bitrates. -tsdmk 23:52, 1 March 2009 (UTC)

Decoding

I did some searching on this and found a bunch of posts claiming that mplayer doesn't even support inloop deblocking to begin with. And of course, while trying to find some kind of setting I could specify in mplayer.conf, I came up with nothing. I have (expectantly) found h.264 playback to be fairly crappy on the Wii, so any speed improvements would be helpful. So far I have found that I can either have smooth video with audio that begins to move out of sync, or I can have video and audio in sync with framedropping enabled resulting in a choppy playback. Or, depending on the encoding of the video, an unbearable slideshow with an audio track. --Flark 03:05, 3 May 2009 (UTC)

Nevermind. According to rodries, the skiploopfilter option for h.264 is already set internally. So there isn't really anything more that can be done at this point. Yes, I've asked. --Flark 10:02, 3 May 2009 (UTC)

DVD Menu selection and controls?

Any plans on being able to use the wiimote D-pad/pointer and the A button for enabling use of a DVD's menu?Nintendo Maniac 64 01:53, 27 February 2009 (UTC)

I too would like to see this implemented.--TopGun96 14:06, 27 November 2009 (UTC)

Use the modifier key. — Extrems (talkcontribs) 15:34, 27 November 2009 (UTC)

Skin Featured on Thumbnail

The background on this page (Image:MPlayer_CE.png) was not the background I got when using I think version v0.21d from the Homebrew Browser. Is the background new in v0.3? Because I think it's better than the one in version v0.21d. --Mjbauer95 04:46, 28 February 2009 (UTC)

Okay on the image: Image:MPlayer_CE.png it says v0.3 so maybe I'll have to try the latest version --Mjbauer95 04:46, 28 February 2009 (UTC)


documentation

where can i go to learn how to use it? for example, my wii and TV are upstairs, used by my non-technical wife. my computer is downstairs. when she wants to watch something, i've been carrying the SD card downstairs and transferring the AVI to it, then carrying it back upstairs where she uses mplayer on the wii to watch it

how can i set it up so that she can access my computer over the network from the wii upstairs so that i don't have to physically copy everything to the SD card?

Scroll to the bottom of this page for tutorials, and grow some backbone while you're at it. Or, keep being your wife's little pet... whatever. -Flark 15:24, 22 March 2009 (UTC)
disregarding the irrelevant comments about my personal life, that page doesn't say where the config files go . should i put them in the root of the SD card or should i put them in the apps folder or in the mplayer folder?

You should keep them where you found them (in this case in the mplayer folder under apps), you should edit only the smb.conf file) read the readme file you find in the mplayer folder. —Preceding unsigned comment added by Fanonly (talkcontribs) 10:05, 27 June 2009 (UTC)

Is reinstalling DVDX really necessary?

I already updated to 4.0, but I've tona's cIOS installed for this occasion so I can still install the USB 2.0 cOIS. But unless I can get someone to rewrite the DVDx installer to use it, I'm out of luck. Although I'm confused why do you need to reinstall DVDx since other homebrew applications can use cIOS with out that step and other can detect which IOSs are installed already, so why is MPlayer any different? Stevey 17:57, 29 March 2009 (UTC)

Should this be the official MPlayer?

This app is much better than the original that Team Twiizers made (they have other things to do), and their version doesn't have anything that's better than MPlayer CE. Could Team Twiizers just classify this as the official Wii DVD player?

What difference does it make? MPlayer is, as you say, 'official' because they developed it for the Wii. MPlayer CE is independent of TT, so they are unlikely to make it 'official'. - InfernoZeus 21:01, 29 March 2009 (UTC)
There is no "official" player. It doesn't work that way. -Flark 02:21, 1 April 2009 (UTC)
Actually this is a good point, there is no "official" player, so I've moved the TT port to a difference page name and added a disambiguation page. --Tantric 03:02, 1 April 2009 (UTC)
There could be only one really "official" player, and that player needs to be made by Nintendo... Drag0nflamez 09:30, 20 June 2009 (UTC)
No, you missed the point entirely. The point is that everybody and anybody can develop what they like (wild west) and there is nobody who can say with absolute authority that "this is the official BLAH BLAH". Such a person would be a bag of wind spouting meaningless nonsense with no real grasp of reality. --Flark 08:42, 21 June 2009 (UTC)

cios update for usb2

from the changelog: "USB ethernet now fixed with USB 1.1; USB 2.0 fix requires an updated cIOS" so does this update actually exist? where can I find it? --Krall 11:29, 23 April 2009 (CEST)

You can find it right in the downloads section of the mplayer ce google code project page. --Flark 06:38, 24 April 2009 (UTC)

And what about the error -1017? How can we solve it? —Preceding unsigned comment added by Anonimo200 (talkcontribs) 00:29, 25 April 2009 (UTC)

MPlayer-CE v0.5 now works with "USB2.0_beta3" ONLY! Before installing "USB2.0_beta3" you must remove "USB2.0_beta2"! --Drugold 12:18, 25 April 2009 (UTC)
I'm not sure if it is working at 100% but I have cios usb2.0 beta2 (I have been unable to install the last one due to error 1017) and MPlayer works fine (at least the same as version 0.4...) —Preceding unsigned comment added by Anonimo200 (talkcontribs) 14:23, 25 April 2009 (UTC)
I just want to add that I was using cIOS USB2 beta 3 and I was told by a few of the mplayer ce devs to just go ahead and switch to the version on their downloads page. There is a crash problem thought to be introduced by it with SMB shares though, but ONLY if your router is turned off because it has something to do with trying to connect to an access point that for all intents and purposes does not exist. It doesn't happen for everyone, and a fix may have already have been found by rodries. --Flark 21:45, 25 April 2009 (UTC)

trouble with USB hard drives

I have MPlayer 0.6, I followed all of the instructions including installing hermes usb2 cIOS successfully. I have two USB drives, one WD 250GB Passport, and one older Iomega 250GB drive. When I select USB in MPlayer sometimes it will list the contents of the drive fine and can play the video perfectly. Othertimes it shows no list at al on top of the background. I would say it's a 9/10 failure rate. I've tried all sorts and can't figure out a pattern of when it works and when it doesn't. Both drives behave in the same way (only one plugged in at a time). Does anyone have any ideas if this can be resolved please?--Wilsoff 12:12, 24 May 2009 (UTC)

Great work. 0.61 works like a charm... every time with both HDs and with my USD stick. Thanks!--Wilsoff 09:50, 26 May 2009 (UTC)

I'm having the same problem with ver 0.75 It's started taking a long time to display a file list and when it does it frequently only shows the first 6 or so files in the folder. I'm using the old 160GB hard drive from my laptop in a Transcend SATA case, (USB bus powered). JP 10:46, 27 October 2009 (UTC)

question on Hermes USB cIOS

Is there some more information on Hermes USB? Maybe source code or a wiibrew wiki entry would be great, if it is really better than the old cIOS. E.g. I would like to know whether installing Hermes USB cIOS will prevent any other homebrew apps that use the old USB2 cIOS from working?

Further I would like to know, whether it is possible to use the LAN adapter and a USB hard drive with both plugged in at the same time... e.g. to listen to web radio and then play a movie from HDD without having to crawl around and replug everything. delirium83 16:55, 25 May 2009 (UTC)

More information can be found in Spanish on http://www.elotrolado.net. And yes, with the latest MPlayer version and Hermes' cIOS, having the LAN adaptor and USB harddrive together is possible. --AgentX 21:51, 25 May 2009 (UTC)


SMB

Is it possible to connect to an external hard drive connected to a PC through SMB? malexous 21:34, 5 June 2009 (UTC)

Of course, why not? That hard drive acts just like one inside the computer. --Tantric 07:07, 6 June 2009 (UTC)
I'm having trouble connecting to it. I've tried using/not using my password and the hard drive isn't idle. Should I be directing the smb file to E:/Media, for example, or just Media. malexous 10:39, 6 June 2009 (UTC)
I got it to work. The problem was my ignorance. Thanks for the reply. malexous 10:58, 6 June 2009 (UTC)

I've got a problem which equals to the one written above. I'm using Windows XP Home and have a share there which redirects to my external hard drive. However I can not access it through MPlayer CE 0.62. My smb.conf has these lines:

#Samba share1  (smb1:/)
ip1=192.168.1.1
share1=audio
user1=
pass1=

Since XP doesn't require an user account it should work but trying to access it instantly gives me the "error reconnecting to smb1"-error. Youtube etc. does work so the application has access to the internet. Any ideas? --arn` 14:07, 3 July 2009 (UTC)

I'm way late here, but in case anyone else has this issue/you still haven't solved it, it seems unlikely that that's the IP of your computer; it looks a whole lot more like your gateway IP. You don't want the Wii to connect to your router to access your media, you want it to connect to your PC. Thus, you need to find your PC's IP (simplest way is probably to enter "ipconfig /all" (no quotes) on a command line and look for "IP Address". In the above case, the IP will probably be 192.168.1.*. - Vague Rant 14:32, 23 August 2009 (UTC)

I'm so confused, what do I do? Can you tell me step by step please? --RPD490 23:36, 2 December 2009 (UTC)

USB Test Values

We are in wiibrew web and we must follow the rules, so please don't do any reference to loaders here. —Preceding unsigned comment added by Rodries (talkcontribs) 15:02, 29 June 2009 (UTC)

Please post all values as asked via the mplayerce news post. Thankyou Djdynamite123 23:08, 23rd June 2009 (UTC) —Preceding undated comment added 22:10, 23 June 2009 (UTC).

i gave it a shot, values for the usb came up as 0 and the drive mounted and displayed files and folders fine. i then got a value of 5.whitegoose 18:45, 24th June 2009 (UTC) —Preceding unsigned comment added by Whitegoose (talkcontribs) 22:48, 24 June 2009 (UTC)
I tested my Seagate Freeagent usb HD having 2 partition (the first one is FAT32 and the second one is ext3). I got a negative value: -2021 I tried to convert the FAT32 part. to NTFS and I got 0 value. Unfortunately NTFS is not yet supported. --F1cund14n 07:24, 25 June 2009 (UTC)
Is it possible your old FAT32 partition was not created as primary and active? whitegoose 09:20, 25th June 2009 (UTC) —Preceding unsigned comment added by Whitegoose (talkcontribs) 13:24, 25 June 2009 (UTC)
F1cund14n: I'm improving test program, I'll release a new version very soon, also be sure fat32 partition is primary and active. Rodries 17:21, 25th June 2009 (UTC) —Preceding undated comment added 17:21, 25 June 2009 (UTC).


heres mine! theres two logs here. hope this helps! http://www.pastie.org/524870 whitegoose 19:01, 25th June 2009 (UTC) —Preceding unsigned comment added by Whitegoose (talkcontribs) 23:04, 25 June 2009 (UTC

Hi whitegoose, this log tell me that your 2 usb devices is fully compatible with new usb2 driver. Thanks for your logs. --Rodries 08:54, 26 June 2009 (UTC)
no problem. let me know if i can be of any help or if you need any guinea pigs for new stuff whitegoose 07:17, 26th June 2009 (UTC) —Preceding unsigned comment added by Whitegoose (talkcontribs) 11:22, 26 June 2009 (UTC)

Here is mine too, http://www.pastie.org/525369 That's from a netway ide to usb adapter with a 1,8" Hitachi hdd inside. rhoderik —Preceding unsigned comment added by Rhoderik (talkcontribs) 12:38, 26 June 2009 (UTC)

Your log is telling me that your usb device doesn't support SCSI_TEST_UNIT_READY (you can see it executed 5 times) command but there is no problem because doesn't hang the device. Your deive is fully compatible with the usb2 driver.--Rodries 13:21, 26 June 2009 (UTC)

That is from another test with a Conceptronic ide/sata to usb adapter and a 200GB Sata hdd http://www.pastie.org/525376 It's not even detected, it also doesn't works with an ide hdd inside. rhoderik June 26, 12:43:54 (UTC) —Preceding undated comment added 12:47, 26 June 2009 (UTC).

I need the log000.txt created in your sd, please pastebin that file, thks Rodries 12:58, 26 June 2009 (UTC)
Sorry, that is the log http://www.pastie.org/525426 rhoderik 13:39, 26 June 2009 (UTC) —Preceding unsigned comment added by Rhoderik (talkcontribs) 13:43, 26 June 2009 (UTC)
OK, I need to contact to you directly, send me an email to rodries_At_gmail.com or go to irc on EFNet channel mplayer_ce, your device is very strange I need to create a special dol for you.I'm sure that it's not working with any other usb2 hombebrew application.--Rodries 14:44, 26 June 2009 (UTC)

just thought i would post wht i was using for my HDD. its a 3.5" SATA from a Dell, think its a Hitachi drive. i have it connected with a cables to go USB to IDE2.5/IDE3.5/SATA cable and an external power supply that came with the cables to go unit. http://www.cablestogo.com/product.asp?cat_id=1541&sku=30504 whitegoose 09:49, 26th June 2009 (UTC) —Preceding unsigned comment added by Whitegoose (talkcontribs) 13:54, 26 June 2009 (UTC)

Here is my log,http://www.pastie.org/525679 I'm using a western digital elements 640gb. lildude 17:47, 26, June 2009 (UTC)

Your device is 100% compatible--Rodries 17:57, 26 June 2009 (UTC)

I have a Seagate 250GB, a Western Digital 500GB and a Thermaltake USB/SATA docking station. Previously I had trouble detecting the USB HDD with other usb2 hombrew applications. Here is my logs, Seagate: http://www.pastie.org/526329. WD: http://www.pastie.org/526332. —Preceding unsigned comment added by Kwirky (talkcontribs) 12:06, 27 June 2009 (UTC)

I have a Western Digital "My Passport Essential" 250GB. Here is my log: http://www.pastie.org/526363 -"Analise USB Device Test v0.4" does NOT create a file "log000.txt" on SDHC card. SD card ONLY! Drugold 17:31, 26, June 2009 (UTC) —Preceding undated comment added 13:34, 27 June 2009 (UTC).

Here is my log, http://www.pastie.org/527110 , I have had to use Mplayer CE v0.5 as later versions freeze for a while when starting video.--Rudi 13:37, 28 June 2009 (UTC)

Here is my log http://www.pastie.org/527164, LaCie Little Disk 250GB, previous versions didn't work but this worked like a charm. —Preceding unsigned comment added by C64rmx (talkcontribs) 15:26, 28 June 2009 (UTC)

My logs: Pretec 1GB USB 2.0, which seems to work. And the problematic one: Corsair Flash Voyager 8GB USB 2.0 gives usb2 init: -2201 code. The latter also can not be detected with lsusb app anymore (maybe after some of the HBC upgrades, as it was working fine before), and another stick from the same manufacturer is not detected either. Mike k 12:39, 29 June 2009 (UTC)

Hi Mike k I'm interested int your problematic usb device, can you contact with me directly (rodries_At_gmail.com) ? Your log is telling me that your device is usb1.1 Rodries 15:00, 29 June 2009 (UTC)

I have a external Western Digital enclosure with a 160gb Seagate IDE drive inside. Here are the results: http://www.pastie.org/528965 —Preceding unsigned comment added by OneUp (talkcontribs) 03:06, 30 June 2009 (UTC)

Here's my log. again, i did 2 logs using the same device. that first log in the pastie returned a -2089 and i had turned on the HDD before my wii. the second log i turned on the HDD after the wii and it said it was fine. http://www.pastie.org/529205 hope this helps. i might do another log with my old 4gb usb drive i was using for mplayer before and is still recognized.--Whitegoose 11:27, 30 June 2009 (UTC)

Here is my log http://www.pastie.org/529838. This is for a SanDisk Cruzer Mini 1.0GB--JHardin1112 19:53, 30 June 2009 (UTC).

Hi JHardin1112 I need to do some test with your usb2 device, please contact me directly in irc (EFNet, mplayer_ce) or email (rodries_Art_gmail.com)--Rodries 12:59, 1 July 2009 (UTC)

My log http://www.pastie.org/530206 if i start mplayer ce and access the usb it wont find anything however if i then exit the app and start it again i can access the hardrive without issue--Romo12 01:03, 1 July 2009 (UTC)

Romo12 your log tell me that you don't plug usb2 device on port 0, please checkit.--Rodries 12:59, 1 July 2009 (UTC).

My Samsung YP-MT6Z 1GB USB-Flash player log: http://www.pastie.org/530960. "Analise USB Device Test v0.6" writes that the device is 100% compatible with USB2.0. But only works correctly if you plug AFTER the run MPlayer-CE. If you plug this USB-Flash player BEFORE run MPlayer-CE, then it hangs.--Drugold 17:22, 1 July 2009 (UTC)

The new usb2 driver is not implemented in mplayerce yet , next version will be released very soon --Rodries 17:52, 1 July 2009 (UTC)

My log: http://www.pastie.org/532673. I am using a Iomega Prestige 500 GB USB 2.0 Desktop External Hard Drive, mplayerce v.62 does not recognize it at all, earlier versions did every once in a while Moosehunter 23:09, 2 July 2009 (UTC) Your device is 100% compatible with new driver, the next mplayerce version will work fine with your device. --Rodries 07:43, 3 July 2009 (UTC)

Sometimes it fails to initialize my WD HDD the first time after a cold boot. Try it again and it works. Here is the log. Fail: http://www.pastie.org/534735, Success: http://www.pastie.org/526332. Kwirky 13:41, 5 July 2009 (UTC) It's a known issue, some devices hang the first time, but I don't know how to fix. I've uploaded a new test.dol to try to fix this issue, but it's not sure that fix it.--Rodries 16:13, 6 July 2009 (UTC)

My log: http://www.pastie.org/535872. MPlaery didn't work with past versions of IOS202 (though "normal" USB worked fine). The test program says it is 100% now. Hope it is so :). Thanks for looking into this... Broody 6 July 2009 —Preceding undated comment added 17:08, 6 July 2009 (UTC).

My friend's 2GB Toshiba drive is marked as incompatable, the log is at http://www.pastie.org/536500.txt Uberushaximus! 02:02, 7 July 2009 (UTC) Try v08 test.dol. If it doesn't work I need to do more tests with that device, please contact me via email (rodries_At_gmail.com) or irc (irc://irc.efnet.net/mplayer_ce) --Rodries 10:54, 7 July 2009 (UTC) That worked! Results are here http://www.pastie.org/540532.txt Uberushaximus! 20:54, 9 July 2009 (UTC)


How can i select diferent subtitles, it only appears the default subtitles? —Preceding unsigned comment added by Edgarmgp (talkcontribs) 18:11, 10 July 2009 (UTC)

Lacie 1TB drive designed by Neil Poulton. Activity light flashes (requires turning off and on before accessible again) when homebew channel is launched, mplayerCE is launched, or other usb2 homebrew applications. Files are in accessible on wii or pc in this infinite flashing state. However, if mplayerCE is launched, and the drive is working with pc, I can hotswap and goto 'open a file,' and video is accessible and will play fine. Test log: http://www.pastie.org/542431 - Any help appreciated. USB 2.0 cios installed as according to http://code.google.com/p/mplayer-ce/wiki/USB20 —Preceding unsigned comment added by Lost101 (talkcontribs) 16:37, 11 July 2009 (UTC)

v1.0 Test (drive turned on during launch of HBC) - http://www.pastie.org/559256 | v1.0 Test (drive turned on when in HBC) - http://www.pastie.org/559260 Lost101 09:00, 26 July 2009 (UTC)

USB 2.0 was working in the last release but no longer -http://pastie.org/544695.txt —Preceding unsigned comment added by Startreker (talkcontribs) 20:52, 13 July 2009 (UTC)

Hi Startreker please contact me via email (rodries_At_gmail.com) or irc (irc://irc.efnet.net/mplayer_ce)--Rodries 07:22, 15 July 2009 (UTC)

I have a WD 1TB MyBook Studio, http://www.pastie.org/551106, first time it gives me this, the second time i try the detection it works.. (Nico402 11:23, 19 July 2009 (UTC)) Hi Nico402, can you do the test again with the new test.dol (v1.0)? I need the new log, also try to contact me by email or irc channel. --Rodries 11:50, 23 July 2009 (UTC)


Putting in a table where we can put in test results, since the paragraphs above are hard to get any information out of. Thav 02:19, 29 September 2009 (UTC)

Make Model Size Works? Comments Tester
Corsair gizmo! 2GB 100% USB support broke for me when upgrading from v6 until I ran cios_installer again to get 202 Thav 02:19, 29 September 2009 (UTC)

libdvdnav

Is libdvdnav going to be functional soon? I have to keep MPlayer TT on my SD card to play many of my DVDs because they only work with libdvdnav. When I try to use libdvdnav in MPlayer CE, it will start playing and then crash. Plus, I can not get the modifier button (2) to work so that I can select the option I need to play the movie.--MattMan 22:25, 14 July 2009 (UTC)

Hey, awesome!!! Version 0.72 has functional libdvdnav! Time to finally delete the old MPlayer TT.--MattMan 04:14, 10 August 2009 (UTC)

NTFS - Why it's essential

Other discussions have stated they can't understand why NTFS is a priority.

I think it's time to pause and think about what mplayer-ce is for. Yes it's fun to prove something can be done, and it could save you buying a DVD player if you can play DVDs on the Wii.

The whole point of media player software (in my opinion) is to reuse your existing hardware(Wii or PS2) instead of having to go and buy a popcorn box, WDTV or similar. These physical media players charge a lot for not doing much.

In the future more TVs will probably have USB ports for media playing. More PVRs might have better usb transfer/playthrough.

As with a lot of people, I already have a USB backup drive. This is NTFS so I can store 4gig plus file sizes. These could be virtual PCs or MS backup files.

I want to be able to store the videos I download from Youtube, or videos I take on my camcorder(and then convert) on my USB drive and play them on the TV.

It's cost me less than £5 in total rather than £80-£200+ (uk)

This also stops me having to buy those stupid digital photo frames.

I do admire what's been done with MPlayer-ce, but I won't be using it for these reasons. I'll be using geexbox so I can play off my usb drive. -- JamesA 12:08, 14 August 2009 (UTC)

Last time I was talking with the devs about some trouble I was having getting mplayer_ce to load off my thumbstick, there was someone working on a library for reading ntfs. That was probably a week or two ago, and AgentX seemed pretty pleased with the progress so far. --Flark 00:39, 15 August 2009 (UTC)
Yes, Shareese (with help from rodries) has ported NTFS-3G to the GC/Wii.
When the next version of MPlayer-CE is released (soon?) it will most probably feature NTFS support; If you cannot wait for the next release and are able to build MPlayer-CE yourself, you could checkout the source (use the newgui branch) and replace the FAT mount code with the NTFS mount code (its only like 2-3 lines in 'mplayer/osdep/plat_gekko.c').
Off the record, I am using a NTFS-enabled build of MPlayer-CE currently and it works absolutely heavenly, hopefully rodries will make a official release in the near future. --Rhys 01:01, 16 August 2009 (UTC)

No Shuffle/Random Playback?

This is one of the most standard features of media players and MPlayer CE doesn't even have it. The abandoned DragonMedia Player has a shuffle playback function and it's the only thing preventing me from using MPlayer CE as my main Wii music player. (Also its glow effect with the music is rad :P)

Also, is there anyway to play media files from seperate folders? I'd like to have 3 different folder based on content, but I'd like to play them together at times. Nintendo Maniac 64 20:22, 15 August 2009 (UTC)
Sequential/continuous play will be added in next release, it will play all files within that folder or share, etc.
Ok... any plans on shuffle/random playback though? I can't even use MPlayer CE for my needs until that gets implemented, but I really want to because as an audiophile DMP has lesser audio output and can't play FLAC. Nintendo Maniac 64 03:49, 29 August 2009 (UTC)

Using MPlayer in your own software

I'm just wondering, how much work would it be to use the MPlayer source to display a video in your own software? And then still draw things on top of it. I had this idea of showing music videos on the background of GuitarsOnFire. --Daid 09:58, 20 August 2009 (UTC)

It wouldn't be trivial - a fair bit of work. --Tantric 13:35, 20 August 2009 (UTC)
Ah, that's a better answer then "rightout impossible!" And I don't mind a challenge ;) First GoF release 1.0 and then I'll go and see how far I get. --Daid 13:48, 20 August 2009 (UTC)
Daid, i like the idea, sounds Awesome!--Hatredg0d 14:19, 20 August 2009 (UTC)

Translations

Hebrew - 0.75 - File:Mplayer ce 075 heb.zip --Elisherer 14:08, 21 August 2009 (UTC)

Add .dpg support

.dpg or nDs-mPeG is the video format of Moonshell the homebrew media player for the Nintendo DS. Here is a link to all the technical details of the format. http://en.wikipedia.org/wiki/NDs-mPeG

Interestingly if you change the extension of a .dpg file to something supported by Mplayer_CE (ex. mpg) after analyzing the video plays fine but without sound. Secondarily in linux with mplayer and essential codecs packages installed. If from the command line you do "mplayer video.dpg" you get sound but no video. This is becuase the standard MP2 audio format is recognized but not the video. If Mplayer_CE (in just the case of opening .dpg files) could be forced to use MP2 sound after it analyzed the video I think it would work fine.--Linus 02:14, 31 August 2009 (UTC)

For testing purposes I converted the may 2009 homebrew showcase to dpg. http://rapidshare.com/files/273677381/showcase.dpg.html --Linus 02:52, 31 August 2009 (UTC)

Jpeg Image Viewer?

PLEASE PLEASE PLEASE put a jpeg image viewer on here! Even if it comes 5 versions from now, I'd be at ease. I just hate having most of my manga that I read on my wii be scrunched onto the left third of the screen (a linux problem with WiiReader). Can you at least respond to me and tell me if you would consider it or not? --Williamdude1 00:43, 25 September 2009 (UTC)

Have you tried WiiXplorer? It has an image viewer that supports JPEG. Nintendo Maniac 64 02:29, 6 October 2009 (UTC)

Sleep Timer

Geexbox has a nice feature which lets you set a sleeptimer and shuts down the Wii automatically, which is great for people like me who likes to fall asleep watching movies. Any chance of implementing this into MPlayer CE? --Corey89 16:53, 29 November 2009 (UTC)

Instructions link for installing without WiFi is broken

It looks like the domain is no longer maintained for the discussion forum where this was once held. Is there another location for the directions?

I had to break up the URL so this post wasn't flagged as spam.

http://www.tehs - keen.com/forums/showthread.php?p=62838#post62838

Muskr 18:12, 30 January 2010 (UTC)


YouTube playlists

Two things I notice about playing YouTube users. Sometimes I want to play them in the order in which they're added, which is the reverse of how they're listed now. I made a copy of the XML tag that mentions JamesNintendoNerd, and replaced the name with RedLetterMedia, and in the resulting view, all his multi-part reviews appear in reverse order. Is there a heretofore unknown attribute that will reverse the incoming list? --Unbibium 06:37, 16 May 2010 (UTC)

Also, whenever a new video starts, the menu appears on top of the video and I have to press 1 to make it go away. Am I just pressing the wrong button somewhere, or should I file a bug? --Unbibium 06:37, 16 May 2010 (UTC)