Talk:GeeXboX

From WiiBrew
Jump to: navigation, search



How Can I Add Codecs?

I want to be able to play MKV files but it seems the GeeXboX doesn't support it by default. How can I add it?

Nevermind, did some research and I found out MKV was just a container. :P

Second stage of operation system

If i load this - downloaded and inserted folder apps into root of sd card and after that runned with homebrew channel - i load and black screen white font and some text and ends with - some files missing or corruptted - or format card (or something like that but the base is right) and the second stage of system could not be loaded.I want this on my wii-please help me...i really need this.

  • Ugh, I have the same problem and its frustrating to no end! And I followed the EXACT instructions too! What am I doing wrong?! Chaos4ever 23:54, 23 September 2008 (UTC)

when you unzip the archive you get the apps/geexbox folder and the other GEEXBOX folder, you need both on the card, the GEEXBOX folder should be on the root of the SD card.--Maduin 21:44, 28 January 2009 (UTC)

Visualizer dimensions

I might be missing something really obvious here, but is there a way to change the dimensions of the music visualizer from 640:240 to full 640:480? Those black bars are killing me.

Yes you can, its in one of the config files in the GeeXboX folders, you can edit it with notepad. The wii is too slow to handle 640x480 though. I went with 320x240 to get the full screen. Since its on the tv the low res doesn't look too bad. --Llvanden 08:59, 22 September 2008 (UTC)

What video formats does it support?

Well, all videoformats that MPlayer supports, click here to see what is supported: http://en.wikipedia.org/wiki/MPlayer#Supported_media_formats

MP4s are running super choppy for me. Can't find any info about this. Any settings I can change or you can fix? Running the latest alpha on sysmenu 4.0, tried both front SD and USB hard drive to no avail. AVI is fine. Would have submitted on sourceforge but you need an account. psyck0 05:29, 5 June 2009 (UTC)

Stream

Is it possible for this to read off of my mac that is set up to share all files through HTTP? I guess that since this is on the whiite kernel that wi-fi is still missing? Pinball wizard 03:51, 17 July 2008 (CEST)

The wifi still is indeed still missing . SF49 11:11, 17 July 2008 (CEST)
I do see a network configuration settings file included in the GeeXboX distro, even referencing wifi. Is this just ported over, yet considered 'broken', does it rely on a third-party wifi connection, or added in the latest build?Steve32 18:47, 21 October 2008 (UTC)
GeeXboX (other than most other Homebrew applications) runs under Wii Linux and not natively as a Wii application. Therefore, a completely different network stack is used (i.e. the Linux stack). Consequently, Wii Linux requires its own drivers for system periphals of the Wii console. Unfortunately, there is no driver available for the internal Wifi card at the moment! Those Wifi settings you see are therefore meaningless. What works with GeeXboX are USB-Ethernet adapters. In fact, GeeXboX even supports a larger number of USB-Ethernet adapters than the Wii itself does! I have one very cheap one "KH-886" which does not work for the Wii operating system but does work in Wii Linux (and GeeXboX). So, for the moment you need a USB adapter or need to wait for driver support... - to.rben 18:27, 24 January 2009 (UTC)
Any news on this? The wifi driver is working now, heres hoping for a new build in the coming days :D Someguy 11:42, 29 August 2009 (UTC)

NTFS

Is there a licensing issue with the use of NTFS? I have always wondered why my linux versions could never read my windows drives. And I have a 320GB external HDD, but I dont want to go around breaking it up into tiny partitions just so its FAT32. --Llvanden 12:54, 18 July 2008 (CEST)

FAT32 can handle HDD up to 2000GB. Use a better formatting tool. Felix 13:14, 18 July 2008 (CEST)
Linux has had NTFS read support for a very very long time.--Canumbler 06:41, 23 July 2008 (CEST)
I see, thanks for the format tool. I will try it once I finished emptying my HDD. I didn't know about the linux NTFS support, however, the version that GeeXboX runs off doesn't have the NTFS driver, does it? --Llvanden 11:24, 27 July 2008 (CEST)
Yes, it does, as far as I've found it works fine. I use my USB powered NTFS formatted external laptop hdd with no issues at all.--Canumbler 10:32, 28 July 2008 (CEST)
So actually GeeXbox can support USB hard drive? From the article I could only find USB card readers and memory sticks. Or does USB storage mean also USB HD? --anolma 15:45, 6 August 2008 (+2 GTM)
Yes, I can confirm it works with my 320GB NTFS external USB drive. And the speed is good enough for high quality videos too. --Llvanden 14:33, 8 August 2008 (CEST)

Bug

When loading GeeXBox, the progress bar gets to about (what i would estimate to be 60%) and then my wii shuts down (red lights) complete shutdown. --Navarr 18:45, 19 July 2008 (CEST)

Mine does something similar at the same place as yours (about 60% on the bar), except instead of shutting down, mine just freezes. --Sli 03:15, 22 July 2008 (CEST)
this happened to me after using GeeXboX without problems for some time... I deleted the SDROOT/geexbox and SDROOT/apps/geexbox folders and copied everything over to the SD card and it worked fine again. Maybe try that too --delirium83 18:06, 23 July 2008 (CEST)

Found two things: 1st there doesn't seem to be any vsync, so there is some flickering going on on the screen. Also, audio seems to be offset by just a few milliseconds on the 3 or 4 movies I watched. Except for this, it's still an awesome app! --Jfitie 11:55, 25 July 2008 (CEST)

I'm having a problem with the colors in the geexbox program, they all seem to be inversed. The colors of everything else on the Wii are unaffected and I have reinstalled the program a number of times and each time I try the colors of the splash screens and movies I watch have reversed colors. --4N1M3H34D 03:05, 30 July 2008 (CEST)

Since version 0.1alpha2 videoplayback sometimes "hangs". I did not have this problem before. I changed back to 0.1alpha1 and saw a very few minor hangs, but not as much as 0.1alpha2 has. I tried with different video's. Same result. Maybe important: I play DIVX videos with subtitles in SRT format. Maybe it's the new Mplayer used? --DigDug 19:36, 9 August 2008 (CEST)

I tested more and the 0.1alpha1 has the same problem. 0.1aplha0 definitly not(tested). The video problems with alpha1 and alpha2 come when you play a movie with subtitles. --DigDug 22:19, 9 August 2008 (CEST)

Tested it again with 0.1alpha3 and all lagging/hanging has been gone! Great work! --DigDug 06:37, 2 October 2008 (UTC)

XMMS

Any intention to include xmms plugin? I would be really happy if I could play sid music in my wii.

DivX support?

Could someone clarify if GeeXboX supports DivX video files? The topic that asked what video formats GeeXboX supports says it supports everything MPlayer supports. And the link given with the list of file formats supported by MPlayer doesn't mention anything about DivX, but I know the MPlayerWii application supports DivX so I'm a little confused. Thanks. :)

DivX is a kind of MPEG-4 Part 2. Felix 13:35, 22 July 2008 (CEST)
Yes, DivX is supported :-) --Solcott 07:29, 23 July 2008 (CEST)

Messed up signal

When running GeeXboX in 480i with component cables, the screen is all garbled. It appears as if it wants to force 480p. My TV has component inputs, but does not support 480p. Would it be possible to make it check with the system menu data for the resolution, rather than setting it based on whether the component or composite cables are plugged in?

I agree, I have the same problem. My TV supports 480i with Component cables but not 480p. - Jiiprah
Same here. HisshouBuraiKen 13:19, 19 December 2008 (UTC)

Small suggestion

This is just a small, low priority suggestion. When you are changing the volume or seeking, with + and -, you can't hold down the button to do it faster. You should make it work to hold down these buttons to do it faster.

Music mode

I have looked all config files and cant get rid off those annoying geexbox tuxes. Is it possible to remove them or do i have to suffer? --Quu 21:59, 26 July 2008 (CEST)

Huh? What is 'music mode'? Perhaps this will help http://wiibrew.org/wiki/Homebrew_apps/GeeXboX#Themeing ? Flark 01:24, 27 July 2008 (CEST)
Umm, I mean: when you listen music and there is this nice vizualization, tux'es pop (GeeXboX logo) out on middle of screen and it is kinda annoying. Quu 09:32, 27 July (CEST)

Widescreen Issues

The changes made to better suit widescreen dispays have not helped. In addition to pillarboxing, geexbox is now also (slightly) "letterboxed". Flark 09:30, 30 July 2008 (CEST)

I tried playing with the settings file to adjust the screen but doing that just ended up giving me giant gray boxes where the menu text is supposed to be. And I still have pillarboxing. farter, have you looked at Homebrew Channel/Bugs#Black Vertical Bars?
GeeXboX has pillarboxing because it's based on Wii Linux, I posted a patch for Wii Linux to the gc-linux mailing list.--Pepsiman 11:18, 1 August 2008 (CEST)
I think GeeXboX should be using the monitoraspect=16:9 option for mplayer. --Pepsiman 11:20, 1 August 2008 (CEST)
For those of you running 480p pal at 16:9 on an lcd tv use these settings in the settings file:
WIDE=yes
PIXELASPECT=1.1
Remember to use a nix/binary mode compatible text editor to edit the settings file, otherwise the menu fonts will be displayed as filled boxes.
These settings work fine for 99% of the 16:9 videos I have. The only "problem" is there will be that the video doesnt fill the entire screen area (needs overscan?). Some 4:3 videos will still not display right though. --Llvanden 14:46, 8 August 2008 (CEST)
Nope, doesn't work, but thanks for reminding me to use the right editor. I still have black borders all the way around the screen. See above. Flark 04:58, 9 August 2008 (CEST)
Thats what I meant with "Doesn't fill the entire screen area". The 1.1 setting offers the correct aspect for 16:9 movies but leaves a 1cm to 2cm black border around the video, that why I said it might need or fake overscan. If you change the setting to 1.2 it fills the full vertical space but stretches the vid a bit. --Llvanden 15:02, 12 August 2008 (CEST)
Sorry, my friend. Setting to 1.2 doesn't get me to the edges of the screen either. Bummer. I hope the gclinux guys will fix this soon. --Flark 15:08, 14 August 2008 (UTC)
PIXELASPECT=1.2 worked for me on PAL Widescreen 16/9. But in version 0.1alpha4 this option is no more available. To set screenratio lets me not avoid black borders. Can somebody help - or give us back the PIXELSPECT-Option, please!

So the MPlayer TT port seems to automatically detect the Wii's Widescreen setting, and scale the video appropriately. Any chance GeeXBoX could be changed to use this same technique? --thaMANSTA

Video playback error (0.1alpha2)

Apparently, this is not my Wii. I just downgraded back to 0.1alpha1, and video playback works. After reading tha changelog, it must be tha latest Kernel update.

File type trying to load: .mp4 Video Code: V4PM

Any suggestions?

Things to Fix

Hey! GREAT, GREAT APP!!! I've been using this for the whole weekend, watching my favorite videos right on my tv. This is the only app that plays video from the USB flawlessly ;)...

I've noticed a few things that I would like to be different...

1-Volume

The playback volume gets reset every time new file is played. You should make it application independent, while its like file independent.

2-Playlist

If I manually chose a file from the file list, when it ends playing, it takes me back to the main menu, instead of playing the next file in the list. Although, this does work when I play from the beginning in order. Also when choosing a specific file from the list, I can't play the next one or previous with the 1-2 buttons.



Anyway.. This is the best media player so far. Very complete, useful and nice looking ;).. Keep it up!

Video Tearing

I play avis from my usb external HDD and they play very nicely (very good colours compared to stand alone mplayer) + some at a high bitrate. The only problem is that there is fair amount of tearing in the picture. Is there any settings that help with this? I noticed that this does not happen on the stand alone Mplayer. --JustWoody 21:59, 22 August 2008 (UTC)

enable vsync in the options or edit the mplayer.conf file for auto vsync on start up.--Maduin 21:48, 28 January 2009 (UTC)

PAL startup splash screen

Just thought I'd inform of a 'feature' that I have noticed - I have a PAL Wii and when ever I set the Wii to 60Hz (Pal) the splash screen is never displayed instead all the loading console stuff, but, if I set it to 50Hz mode the splash screen is always displayed. --JustWoody 21:59, 22 August 2008 (UTC)

For me, it's the other way around. I've found that setting my Wii to 60 Hz, not only I see the splash screen during bootup, but the aspect ratio is fine for my 16:9 LCD TV.

I had to try and try over and over till I got it working right, but last I made it :)

Bokeron 14:54, 3 October 2008 (UTC)

Well at least someone is getting a proper display on their widescreen tv -_- -Flark 20:58, 3 October 2008 (UTC)

Static net setup slows boot

I don't know why, but when I specify 'ethernet' for my USB net adapter and fill in all the correct IP addresses (host, subnet, gateway, etc) in the 'network' config file in /etc/, the boot process slows to a standstill when the orange bar reaches about 90%. It will take what seems at least a couple of minutes to finish and provide the OSD menu. Network connectivity with SMB nameserver support does work at this point (without having specified static shares). DHCP_TIMEOUT="0" or "1" does not make any difference. This does not occur when I leave all values blank ("") to force DHCP.

Is there a text-only boot option so I can see what is going on, or this is already known among the more hard-core users? I want to test some options, like disabling the HTTP server, skipping the DNS IP, and I need to know what I did to break the Reboot/Quit choices (or was it only in my head that they once worked?). I'm wearing myself out here trying to think about it. Because I'm tired of holding reset for 5 seconds. That adds up to almost (just?) 3 minutes of walking over and hunching ;P I'm Joking here, I know it would be much longer without everyone's collective effort otherwise. More users need to publicly reflect on their experiences to clarify where progress lies. It's all about the entertainment :)

2(+) high-rising media apps, each bringing very promising functionality to the Wii... This has been a great summer! --Zandro 09:06, 10 September 2008 (UTC)

Connecting Wiimote

GeeXboX can't find my wiimote whenever i try to connect it. I have tried both of my wii remotes just in case, but still no success. I followed the instructions and pressed 1+2 as it finished loading, i tried it several times and at different times as well. the remotes work just fine on my wii (even on darwiin), but for some reason they wont connect to GeeXbox. even though the keyboard works, i don't want to have to leave my comp w/o a keyboard. any suggestions? thank you.

Are they syncronizated with the Wii? Duhow 16:35, 30 November 2008

0.1alpha4 not loading

With the new version (0.1alpha4), I've tried to install it several times now, and it never loads past 60% - 80%... The progress bar gets to that point, then everything just freezes. 0.1alpha3 works perfectly fine for me though. --NikoKun 23:47, 24 October 2008 (UTC)

I have the same issue. Even tried a fresh SD card, the same model which the previous version works on. --Zandro 22:02, 24 October 2008 (UTC)
This has already been reported at the geexbox forum and the sourceforge tracker. People really need to stop using discussion pages for bug reporting when trackers are available. It just wastes time for the developers. Flark 06:54, 25 October 2008 (UTC)
If you have version 0.1alpha4 and it doesn't load, lock the SD Card. I heard that it works. Duhow 16:09, 30 November 2008 (Spain)
Confirmed - Simply WRITE PROTECT the sd card and it will boot fine.
Aye, it works most of the time. If it isn't working for you, then try taking the additional step of unplugging any usb devices and DON'T try to connect the wii remote until you can see the menu. -Flark 08:18, 29 December 2008 (UTC)
The above suggestions did not work for me. alpha3 works fine but alpha4 exibits the same bug. Is there any way to boot up in textmode instead of bootsplash? -Saik0 18:30,23 Janurary 2009 (UTC)
Set "RUNLEVEL=debug" in the GEEXBOX/settings file. The bootsplash will show up initially, but then it will disappear, showing you details about the boot process. --Tulkas 17:15, 24 January 2009 (UTC)

FTP server

How do we enable FTP server ? If it is already defaultly enabled, how can we connect to (user/pass) ? --Zaccret 16:39, 1 November 2008 (UTC)

Oops, actually it is en /etc/ftp. The default is geexbox/ftp --Zaccret 16:39, 1 November 2008 (UTC)

DVD support

GeeXboX doesn't have DVD support. Is it related to Wii Linux or directly to GeeXboX ?

Wii Linux. It really needs to be updated... there are a lot of fixes and newer features that it has been missing for a relatively long time. Flark 00:14, 10 November 2008 (UTC)
I thought the new one had DVD support. I haven't got it to work yet, still working on it, but I'm pretty sure it can play them
The version 0.1alpha4 supports ISO/NRG files, so you can play DVD with an external HDD. Duhow 16:12, 30 November 2008 (Spain)

slideshow

Hey can anyone help me out? i cant git it to do sideshows. Does it have to be on a playlist and where does it go? Can someone help me out?

Audio gets 2x faster

It's a great piece of work! I can watch prisonbreak on my wii every week now. However, geexbox seems not compatible to some RMVB files. The audio runs 2x or 3x faster than video... I googled for answer but failed. Found the whitelinux and geexbox both released new version, can not wait for 0.1alpha5 or 1.0... :D_

USB Harddrive, NTFS and ISO

It seems some ISO files play very choppy. Others play fine. Any ideas whats wrong? They are 4.7 gigs DVD ISO rips.

The same problem appears on USD HDDs mit ext3 filesystem. The system load is getting very high and the movie stutters. -Dermartn

More filesystems supported and possible fix of a startup freezing bug

While working on getting geexbox for wii to understand some more unix-filesystems (ReiserFS, JFS, XFS), I compiled my own binaries from the source. On my own wii, I coincidentelly found out that I don't have to set the SD card's write protect notch anymore now in order to get geexbox to run. Unfortunately, I have no opportunity to test it on other people's wiis, so I'm interested in feedback. If you want support for the above mentiones filesystems or are just generally interested in geexbox-for-wii development, please take a look at the respective post in the sourceforge project forum. A link to the binary can also be found there. --Tulkas 21:09, 25 January 2009 (UTC)

Cool, thanks for posting that here...
... BUT it needs a password so I doubt you'll get any testers. -Flark 19:31, 28 January 2009 (UTC)
Damn, stupid me for putting the wrong URL here. It's really no surprise that I haven't got any feedback... I've made it into an http link (instead of https), and it should work without a login now. Thanks for telling me about this, Flark. --Tulkas 09:21, 29 January 2009 (UTC)
Hey, no need to thank me. I was just complaining like any other self-interested end user would. I'm going to go ahead and post this to the actual wiki page. -Flark 21:52, 29 January 2009 (UTC)


0.1Alpha04 modified by Tulkas now boots up correct with my 2gb SD Card, originally never :) - djdynamite123
Thanks for contributing your fixes! I've tested the original alpha4 with 2 different SD cards (1GB Kingston and 128MB Panasonic). Both had quite some free space on it. It only occasionally froze on the 1GB one and always froze on the small 128MB one. I'll test yours with the tiny card and will report back. In the meantime: why don't you commit your changes to the Sourceforge SVN? Would be great to have a second developer on this project. - to.rben 10:53, 30 January 2009 (UTC)
I thought about this, too, but according to Sourceforge's "SVN Browse" view, all that the repository contains at the moment is a tarball with the actual source (which kind of defeats the purpose of an SVN). I actually hoped that farter would upload the source files once he sees that others are trying to help with the development. If nobody else does it, I might do it eventually, but I see a version conflict coming if farter has already worked on his local copy and if it is now different from my patched version. --Tulkas 15:00, 2 February 2009 (UTC)
I tested this with my two SD cards; a 2gb Sandisk Wii branded card, and a 80x 1gb Transcend card, both work beautifully. No more locking the card for me! Pyleic 13:51, February 1, 2009 (UTC)

I tried this version with an SDHC card and it says: Error while processing Geebox second stage system ! Either files are missing/corrupt or the SD card need reformatting. I hope that a version that supports SDHC will come out soon :) --Gerome 21:31, 30 January 2009 (UTC)

Release discussion thread. Some people are bitching and moaning about stuff that isn't even your fault, Tulkas. lol. -Flark 12:52, 1 February 2009 (UTC)

Thanks Tulkas! With you're patched version I can now use geexbox. Previously it was freezing on bootup. --Sshock 02:45, 8 February 2009 (UTC)

This looks great. Just one thing. Is there any chance of support for HFS Plus support for USB? - JP 14:58, 18 February 2009 (UTC)

Wiimote not detected in 0.1alpha6

For these like me who can't use alpha6 because the wiimote can't be detected, here is where you can download the alpha5:

http://www.tehskeen.com/forums/showthread.php?t=10877#edit51118

This will be remove when the alpha6 wiimote connection will be fixed. --Gerome 18:48, 30 March 2009 (UTC)

RTP/RTSP via wifi connection

Question : GeexboX Wii is able to read RTP/RTSP flow on network. Is this action possible on wifi network or do i plug a network adapter on USB? Thank for response Tof95li95/19th May 2009 —Preceding unsigned comment added by Tof95li95 (talkcontribs) 11:49, 19 May 2009 (UTC)


I had the response by reading previous topics see topic Stream —Preceding unsigned comment added by Tof95li95 (talkcontribs) 12:30, 19 May 2009 (UTC)


Audio channels are swapped

It seems that left audio channel goes to the right speager and right channel to the left speaker... everything is connected in the proper way...

Thumbnails - Feature Request

When viewing pictures, it would be nice to see thumbnails. This would allow you to quickly go through pictures, then select the one you want.

I'm using GeeXboX with a usb drive on the wii instead of buying a (stupid) digital photo frame. Thumbnails would make life easier, as you don't always want to slideshow through all the pictures. —Preceding unsigned comment added by James (talkcontribs) 10:58, 14 August 2009 (UTC)

Compatibility issues since alpha 8

The latest GeeXboX (20091016: 0.1alpha8) is having a hard time finding my Toshiba 750GB USB (NTFS) drive. (it won't find it at all) All previous releases were working perfectly fine with my HDD, but alpha 8 can't find it. Other Wii apps with USB NTFS support are still able to read the drive. Any thoughts? --Darkmystery 15:33, 18 October 2009 (UTC)

Subtitle issue with homebrew channel installation

While on GeeXboX#Language and font exist all the necesary info to have GeeXBoX display the subtitles correcty on the user's prefered language (and actually it's the only place I could find on google with the right info), the GeeXBoX version that gets installed via the HB Channel has wrong settings on GEEXBOX/etc/lang.conf that can't display non-english subs correctly: it searches for FreeSerif.ttf but the file included in the "distribution" is FreeSans.ttf (or vice versa). Perhaps it's a typo in the settings file but if you can update it, it would work out of the box for all us poor guys asking around in forums why it displays gibberish instead of X-lang :) Friend 11:40, 8 February 2010 (UTC)