From WiiBrew
Jump to navigation Jump to search


Submit your GUI themes as a tarball/ZIP here!



Here's my theme effort:

Its still got the default font though (which doesn't look great)... plus if game names are too long the text tends to sometimes go over the graphics (which is something I can't change).

If I get the time I might tweek it and maybe tone the colours down a bit. I still think somthing like tantrics libwiigui (or even the style of eke-eke's unreleased genplus GUI) would look much better for this emu though? --Baboon 14:11, 13 March 2010 (UTC)

Very cool, clearly the new default for now :-). I'll add it to the svn archive. Thanks! --SimonKagstrom 14:32, 13 March 2010 (UTC)

Glad you like it. If you decided to keep it (you'll probably have much better offers lol) and you want me to change anything then let me know (or I can send you the psd's if you want the working files)?

With the emulator text as it is there isn't much spacing between the the options and the graphics I supplied - plus the pause/resume is overlapping the blue border? the text will need to be re-aligned or the graphics updated (although I thought having the frodo logo more prominent made it stand out better? --Baboon 18:30, 13 March 2010 (UTC)

Well, text alignment requires source code changes (unfortunately). If you want to make changes, I think you could make the logo a bit less prominent. Personally I also like the square apperance of the red box over the rounded other ones. Anyway, I've submitted it to subversion and made it the default for now! --SimonKagstrom 07:27, 14 March 2010 (UTC)

I've changed the graphics so that the text no longer overlaps the images in the menus's and sub menu's. I've also changed the colours slightly of the images thoughout (as requested I've taken out the rounded corners) and and increased the width of the keboard graphic so that it now covers all of the space behind the right hand side keys (it was clipping before). You can grab the updated images here: Cheers. :-) --Baboon 11:59, 14 March 2010 (UTC)

Great! I've updated the default theme with it. If you send me your email address, I'll give you svn commit access so that you can update it yourself if you change something (you should maybe put your name on the graphics somewhere). --SimonKagstrom 12:19, 14 March 2010 (UTC)

GUI Questions\Suggestions

I'm wondering if it's possible to make the game selection bubble a bit more customizable. Like if you could rather edit fields in a XML file that stores the info on the game entries to include Musician, Coder etc. Also through this a way to assign your own screenshot. If you put a screenshot in a folder designated to that and in the XML file refer to the picture you wanna use for that game. Like say you have a XML file in each folder you make for the games and they look like this:


   <Game Title="Fire Trap">
       Musician = Rub Hubbard
       Coder = Rob Hubbard
       Company = Ocean
   <Game Title="High Noon">
       Musician = Rub Hubbard
       Coder = Rob Hubbard
       Company = Ocean


Is that possible?--Corey89 22:13, 17 March 2010 (UTC)

Well, it's certainly possible, but slightly tricky (I don't like XML parsing!). I also kind of like to have all data in a single file (stored in metadata/). But you can already capture your own screenshots - just enter "game info" and select "capture screenshot". The musician (and graphics artist I suppose) is good ideas though, I'll add these to a future version.
I have some ideas about sharing game information over the network as well, but that's also a future feature. --SimonKagstrom 12:00, 18 March 2010 (UTC)

You could always go by the Lemon64 info field and include Creator, Musician, Genre and Players, it would be easy to find that info then. --Corey89 16:14, 19 March 2010 (UTC)

Another suggestion. Maybe include an option to show or hide the extensions in the game listing, for us who are nazi on organizing and make it look snappy. --Corey89 15:47, 22 March 2010 (UTC)


Loading Games

I dont know if to add it here at the beginning or at the end of the load-block ... In v 8 I got often after playing a game and inserting a new .d64-file after "Insert key-sequence" of 'Load"$",8,1:Run' an error because Frodo types 'Lqad"$",8,1:Run' :-( I have to reset Frodo a few times before I get the right typed "Load"-command ... :-( 15.03.09 18:05 knitax

Usually you should be able to try again with the same load command without resetting. It's a slightly tricky timing issue (silly, I know) --SimonKagstrom 19:17, 16 March 2009 (UTC)

Hi Simon,first thing I want to thank you for your fantastic work. I'd like to share something I accidentally discovered:I just downloaded v.5 and tried to run some of my favourite games (Creatures 2, Zack McCracken, Turrican 2, Myth) but they all failed to load, just like in previous versions of your emulator. I then turned "1541 emulation" on and tried again, but after a long waiting it gave me an "out of memory" error. So I thought to try another game but forgot to "insert" it, basically I just re-loaded the same game(Turrican 2) without resetting and... surprise! It loaded. Creatures 2 and Zack McCracken run fine too (except no intro for Zack) but Myth did not get past the trainer. Just wondering if this can be of any help to you. Another thing, with the new interface I cannot load tapes anymore but only disk images. Thanks again and keep up the good work! Tetsuo 22:28, 16 January 2009 (UTC)

Check that you have the /apps/frodo/tmp/ directory, which is needed for tape loading. --SimonKagstrom 08:13, 17 January 2009 (UTC)
Yes the tmp directory was there, but no tape loading option. Btw, with my method I successifully loaded another game that didn't start previously: Buggy Boy --Tetsuo 13:52, 17 January 2009 (UTC)
There is no tape loading option - Frodo treats everything as disks, so just insert the tape and run LOAD "*",8,1 and it should start. The reason tmp/ is needed is that tapes are first extracted to a temporary file (a "disk") and then loaded as a disk. .prg files work more or less the same way --SimonKagstrom 16:08, 17 January 2009 (UTC)
Thanks for the explanation. I tried but they're not working, I get "?file not found" error everytime. However disabling 1541 emulation makes them run fine(Ghosts 'n goblins, Mr Mephisto)--Tetsuo 17:13, 17 January 2009 (UTC)

When trying to load any .d64 images and then pressing load, it will only result in Device Not Present Error, so far out of 15 games, only 1 loaded, with messed up GFX. Also a suggestion, maybe add a autoload feature so that when you pick the game you wanna play, you can push a button to make it automatically load instead of visiting the menu again. -Corey89

Strange. What games were that? I have not got that error message in any game I've tested (although some fail for other reasons). --SimonKagstrom 19:52, 6 January 2009 (UTC)
Hello Simon, Here are some examples of games that don't work: download d64 from here: [1] [2] [3] Spec 19:18, 10 January 2009 (UTC)
I run H.E.R.O at least. There can sometimes be multiple copies of the same game, some work and some don't. Last Ninja is like this for example.
Well i tried alot of random, but some specifics i remember were High Noon, Terminator 2, Action Biker, World Games, Paperboy, Turrican and Bazooka Bill. The game that loaded was AAAAAh! or something -corey89
At least paperboy works here, I haven't tried the others. Are you sure you didn't press 1 while selecting a game? (A or 2 selects in the menu). Having no disk inserted will give that error message --SimonKagstrom 20:59, 6 January 2009 (UTC)
Yeah pressed A or 2 as mentioned on this site. I'll try to redownload some of these to see if it's the games themselves. But as i mentioned, maybe you should make one of the buttons a autoload button?
Well, I personally think the buttons are more needed as keyboard input, and it's also only three keypresses to start loading :-). Anyway: The source code is available, so please write patches if you have anything you'd like to change! --SimonKagstrom 06:11, 7 January 2009 (UTC)

Thanks for a great app, games that work are great. Although I too have tried a lot of games from and most don't work. Is there something special about their d64 images? Ghostbusters and Bubble Bobble work, Arkanoid, Paperboy, California Games and Beach-head do not work. All downloaded from I get the same "device not ready" message. Is there anything that can be done to fix this, or is it just a quirk of how the d64 images are made and how the Wii executes the code? --Wilsoff 08:38, 20 January 2009 (UTC)

Probably an emulation issue, what you could try is to enable 1541 emulation (from v5 onwards), but if that doesn't work I'm afraid there is little I can do. In the subversion trunk, I've fixed a special problem with some d64 files, but that would be seen as "File not found". As has been said in other parts of this page, try a different version of the game if it doesn't work. Paperboy works for me for example, haven't tried the others you mention. --SimonKagstrom 17:57, 20 January 2009 (UTC)
I've tried a number of games and very few work on v5. However these all seem to work on v6 so thank you! I've also tried a lot of games from a torrent of gamebase 64 v03 and everything has worked so far. There does seem to be some lag on the controls though - v05 worked fine on all the games that worked, but v6 is somewhat unresponsive. For example Park Patrol (from the d-pad works as a joystick, but can be a bit slow to respond - I hope this can be fixed! I'm glad you like the icon - once again thank you for a c64 emu!!!--Wilsoff 11:01, 26 January 2009 (UTC)
OK, good to hear. Then apparently the zero-size-skip option helps in more than corner cases which I thought it would be. The d-pad problems surprise me a bit though, I haven't changed very much there. Is speed otherwise as before? If it works better in v5, it can be fixed, --SimonKagstrom 17:29, 26 January 2009 (UTC)
Sorry it was the wiimote batteries, controls are fine in v6. Thanks for this great emu!

What about USB keyboard support or onscreen keyboard support ala VC's emulator? -corey89

Yes, I've thought about adding an on-screen keyboard (also usable to select keys to bind), but I've not started implemented anything yet. As for USB keyboards, I think they should be supported through SDL. Frodo already has support for this, I just don't know if it works on the Wii (or if the Wii/gamecube SDL port supports it). I have no USB keyboard so I don't have the means to test it or work on it.
Anyway, I use the emulator mostly to play games, so an USB keyboard to type in BASIC programs is not my highest priority ;-). Thanks for the comments by the way! --SimonKagstrom 16:51, 7 January 2009 (UTC)

Got the games loading finally, had to get a different disk file. Also another problem i'm having is the game selection screen, it's way off center, the names are so far left that at times, it only shows the last letter of the game and the file extension. Any idea how to fix it? I use a normal NTSC tv, no HD or anything. -corey89

Good to hear that you got it loading! As for the centering issue, that's a bug triggered by the home-grown menu implementation on long filenames. I'll fix that for next release.--SimonKagstrom 17:27, 7 January 2009 (UTC)


Are the sound bugs being worked on, or is it the emulator itself that just can't emulate the sound properly? -corey89

I've tried to fix those, but I haven't managed to find what the problem is, so don't expect anything soon. It's not the emulator - it sounds fine when compiled on the host. The sound drivers are not the same, but quite similar. This is an area where I'd like other people to contribute :-) --SimonKagstrom 17:53, 12 January 2009 (UTC)
You should ask Tantric or eke-eke for help in that area, they are really good at coding emulators on Wii. I really appriciate your work on this emu though, i spend my whole free time playing old childhood favorites now :) -corey89
The sound implementation is taken from FCEU, so they have been good help already :-). But anyone is free to fix the sound issue of course! --SimonKagstrom 20:29, 14 January 2009 (UTC)

I noticed an overall speed improvement in v.8 (didn't try v.7), which is good, however the music plays too fast. If I reduce emulation speed to 95% the music seems to be at the correct speed but it's distorted. --Tetsuo 16:39, 17 March 2009 (UTC)

PRG Files won't load in recent versions

Doing a clean instal of 2.4.1 (completely deleting all frodo folders before copying it to the SD card) results in PRG files not being able to load in the emulator. This is true of other recent versions as well.

But I found that if I do a clean instal of version 2.1 it will then load PRG files correctly, and THEN if I install 2.4.1 on top of that (without deleting anything) PRG files will load correctly again....

I'm using Ghost Manor.prg but it doesn't run correctly anyway -- after the first stage, the game crashes.... Spikes Peak.prg seems to work all the way through though. --Mr. Reaper (talk) 19:40, 6 January 2013 (CET)


I downloaded it today and it works with my USB keyboard, except that when I press F10 to type a network message, nothing happens and I keep typing into the emulator. --Unbibium 20:24, 13 March 2010 (UTC)

F10 is used to send a message to the other player you are connected to, so it will do nothing if you are only connected to the network (but not another player). You can send messages to the network server (which will be displayed for the next 24 hours for other players) even when "only" connected to the network server. --SimonKagstrom 21:07, 13 March 2010 (UTC)

I would SO download this if it had USB Keyboard support...I like doing BASIC! Also, I kinda like having to type "LOAD" and "RUN" and the like... --Atariangamer 19:19, 7 January 2009 (UTC)

It would also be nice to have a real keyboard on text adventures such as The Hulk - corey89

wait...this new version has keyboard support? DOWNLOADING. --Atariangamer 19:34, 16 January 2009 (UTC)

Well, it maybe had. Version 5 is out now, which removes this support because of a (rather grave) bug it caused. But I'm still interested in hearing out if it worked in version 4! --SimonKagstrom 19:59, 16 January 2009 (UTC)

ah...well, i'll try to load it up today (was away from wii) and tell ya how it goes... EDIT: I couldn't find the archive! you couldn't link to v4, could ya? --Atariangamer 12:36, 22 January 2009 (UT

Sure, it's here: I've been told that the keyboard works except for shift, so it's probably not very useful anyway. --SimonKagstrom 20:36, 22 January 2009 (UTC)

ah, thanks...I'll try both versions (4 'n' 5). But depending on how I like the keyboard, I'd still like for that to eventually become a feature. Now, to download and play! --Atariangamer 22:39, 22 January 2009 (UTC) -- if only I could...It seems to not want to load anything...--Atariangamer 02:08, 23 January 2009 (UTC)

I tried v4 and my USB keyboard !!!WORKED!!! All of the normal keys works worked at the opening screen. I could type my name and type "load" etc, so basic worked. However if I tried to hold down shift the number keys still came out as numbers, not !@#$%^&*()_+:" etc, so still not fully compatible, but a huge step forward. A shame adding USB keyboard support caused other problems, but at at least you know it works in theory. --Wilsoff 10:41, 26 January 2009 (UTC)

Yep, someone else reported that as well. It's probably an SDL issue though since the same code works fine on the host. But as I said before, I'd really like someone else to implement this :-) --SimonKagstrom 17:29, 26 January 2009 (UTC)
I know Simon isn't interested in implementing keyboard support, but can anyone else with a bit of experience in C have a go? There are some keyboard (USB and virtual) libraries in List of development tools, inparticular libusbkbd looks like it might be fairly straight forward to implement. Would this go in main.cpp or somewhere else? If someone can give me a bit of guidance I'm willing to have a go. Although I only have a couple of hours of experience with C (I did a small amount of programming at uni, not much in C though). I've found a lot of games need key presses to start and it's painful having to bind specific keys just to get into the game.--Wilsoff 23:30, 9 February 2009 (UTC)
It should be even easier than that - Yohanes SDL used in WiiApple contains keyboard support. The task should be mostly to compile SDL and SDL_ttf from his svn archive and then link with it. And thereafter figure out why shift doesn't work and why the menu exits when home is pressed (I'm suspecting that the Yohanes SDL joystick support for the wii controller might be responsible for that). Frodo is probably easiest to build under Linux, which is what I use, but with luck it might work out of the box on Windows as well. Base your work on v6 since the current trunk doesn't build on Wii yet --SimonKagstrom 16:43, 10 February 2009 (UTC)

Since v10 the USB keyboard has to be plugged off and in again to work ... :-( 18:05 26.04.2009 @LoganA: Let my entry untouched as I, the author, it intended to be! Knitax) 16:05, 26 April 2009 (UTC)

Really? I have not heard this from other testers. v10 links with a new SDL, but I don't see how this particular problem would occur. Anyway, good that you found a workaround! --SimonKagstrom 16:32, 26 April 2009 (UTC)
Whats the status at the keyboard-front? I was very very happy to find this port for my BASIC-exercises, but my keyboard isn't working :( (it does in the DOSBox-port). A Homecomputer without keyboard-support? ;) But of course: Thanks for your work Simon! --Poeder 17:44, 1 August 2009 (UTC)
Try the workaround above, I don't know why it's needed. I haven't worked on Frodo in quite a while now, but maybe someone else is looking at this (and other issues) --SimonKagstrom 07:58, 9 August 2009 (UTC)

Command errors

When I insert a disk, I do "LOAD '*'8,1 and RUN". However, it takes a good while to do the loading, then usually mistypes RUN (usually doing " UN" or " N"). I even noticed this when trying to type it out in V4 (which sux about the shift). It just wont load...(oh, and does anyone know a why all disk images have annoying "IMPORTED BY:" screens? ><) --Atariangamer 20:06, 23 January 2009 (UTC)

Well, try again - it typically works the second time. I'm working on improving this a bit for the next release.


I should leave no doubt that I am happy that there is a C64 emulator for the Wii. Thank you! From C64 emulators for other systems, I am used to have a PAL/NTSC selector. I found no such thing in Frodo/Wii. Does Frodo emulate a PAL or an NTSC machine? And does it somehow force the output to either? It seems that, on my PAL Wii, Frodo always produces a PAL (50Hz) output. If my reasoning is correct, that implies that all NTSC games will have the wrong timing. Is that so? --Zarchimedes 12:56, 29 December 2009 (UTC)

It emulates a PAL machine, yes (see VIC.h if you are interested). I suppose it's because the original author (Christian Bauer) is a european just like me, and therefore focused on that. I don't know how much difference it makes in practice though, I play a lot of American games (Bruce Lee!), and they work just fine. SimonKagstrom 14:17, 29 December 2009 (UTC)
Many thanks for your kind reply! One example of a game (well, sort of) that behaves differently on PAL machines is "Time Crystal" by Jim Sachs. (If you want to try it, run the game, not the intro.) On NTSC machines, there'll be a (for the time) brilliantly animated T-Rex walking about and roaring, while on PAL machines, the animation is broken. Generally, there was a change of paradigm in how the timing of C64 games was handled. That change took place around the year 1987 (the number is not to be taken too literally; there were exceptions in both ways). Before that change, programmers used to employ the timer interrupt to initiate calls to their music routines, their joystick input handling routines, screen update routines etc. Then raster line interrupts became popular. They made color changes possible that seemed to be impossible otherwise (FLI, for example), they allowed for sprite muliplexing, and they provided what is nowadays known as vsyncing. But syncing the game timing to the screen refresh rate means that games written for NTSC computers run slower on PAL machines, and PAL games run too fast on NTSC machines (or run into trouble, as there is, of course, less time available per frame). This includes the music speed. California Games on a PAL machine must sound awkward to someone who knew it on NTSC computers only. I live in Europe, too, and often thought about importing an NTSC C64 from the US. But I had much trouble with the customs authorities when I imported my Atari 5200, and I don't want do go through that kind of trouble again. Thanks for the port, thanks for your reply; I really should learn how to compile things for the Wii and then port VICE. (But I am afraid that will never happen...) --Zarchimedes 17:36, 29 December 2009 (UTC)
I seem to remember Time Crystal from the days of real hardware, but not the actual T-Rex, maybe simply because I had a PAL C128 :-). Thanks for the summary on where the problems come from! I know VICE emulates the C64 in a better way, and I also took a look at porting it. Unfortunately, it's slightly tougher to get compiling for the Wii than Frodo, in part simply because it's a much larger code base. I've dropped the idea also because I've "invested" too much time in Frodo by now (especially with the network support), and because it works well enough for me. Personally, I'm happy as long as I can play International Karate, Bruce Lee and Way of the Exploding Fist! SimonKagstrom 12:33, 2 January 2010 (UTC)



Please add a menu option to allow resume. Once you press home on the WiiMote it is sometimes difficult ot resume the game. You generally have to change a key bind to get back to the game. It would be great if there were an option on the menu to resume the game.--Wilsoff 11:27, 26 January 2009 (UTC)

Try pressing the 1 key, that acts as "abort" and exits from the menu.


One of my preferred games is Firequest ( Unfortunately, it is not working because it freezes after about 1 minute. I tried also Frodo for Windows and this problem remains. Can you solve this bug, or can you contact Christian Bauer, please? --Rogwb 14:25, 31 January 2011 (CET)