Talk:IOS58 Installer

From WiiBrew
Jump to: navigation, search

Contents

Typo or sign of things to come?

On the wiki page it says "Default in HBC 1.0.8+", but the latest HBC is 1.0.7. Is this in anticipation of a future update, or is that a typo? Also, am I right in thinking WiiMC is gonna start requiring IOS58 to be installed for USB2.0 and use HBC's HW_AHBPROT flags for DVDs? --SifJar 18:15, 11 August 2010 (UTC)

Possibly not a typo, I've reinstalled HBC after installing IOS 58 yet it still stays on IOS61. --I R on 21:22, 11 August 2010 (UTC)
WiiMC is going to start requiring IOS58 (reference: IRC) - newer versions of HBC will probably require this for USB 2.0 loading, but I'm guessing that note comes from IRC too, so it seems sound. --Lukegb 21:25, 11 August 2010 (UTC)

Offline install?

ios 58 installer is posible install offline? --Catuliwiib 00:04, 12 August 2010 (UTC)

For that, you can use NUS Downloader and then wadImport. --Tantric 05:13, 12 August 2010 (UTC)
Thanks Tantric but v6175 correct? --Catuliwiib 05:26, 12 August 2010 (UTC)
Since that's the only version available...yes. --Tantric 15:44, 12 August 2010 (UTC)

IOS58 v6176 Better?

IOS58 v6176 is recommended install or wait more time, and which changes have since v6175 --Catuliwiib 05:32, 1 October 2010 (CEST)

It really doesn't matter, but the latest one would probably be better. --bg4545 08:22, 1 October 2010 (CEST)
know it is neccesary because more new no have be better, is possible occurs bugs with actual HBC or another programs for this is my question--Catuliwiib 17:10, 1 October 2010 (CEST)
I agree with Bg4545 -- it really doesn't matter. The only changes between 6175 and 6176 were an updated WL (wireless) driver -- looks like they just pulled in new upstream code from Broadcom (Aug 4 2008 / 4.30.47.2 vs Jul 26 2010 4.30.47.3). The changes are minor, I doubt we'll ever know what they really changed or why. -- Bushing 15:00, 2 October 2010 (CEST)

Why not use dopmii ?

See comments here about the deletion of an application that install ios 61 and wii shop: Talk:Wii Shop IOS61 and Mii installer --Attila 21:01, 11 August 2010 (UTC)

Because DOP Mii must be run on a trucha-bugged IOS, and has all sorts of options for "patching" the IOS. This tool can be run on an unmodified Wii and installs a 100% virgin copy of IOS58. --Tantric 21:06, 11 August 2010 (UTC)
Really? I thought it could run on any IOS, it only needs a trucha-bugged one to install modified IOSes. If you want to install a clean IOS on a clean Wii, I think it would work just fine. Yossi 00:15, 12 August 2010 (UTC)
Uh, no. DOP Mii clearly tells you that you must be running an IOS that accepts fakesigning. And that's what DOP Mii does - it downloads contents, decrypts, patches if you asked it to, then encrypts and installs. --Tantric 01:54, 12 August 2010 (UTC)
Then how about WiiSCU ? The latest version of that has an option to install IOS58, patched or not, and you only need an IOS with the trucha bug to install the patched IOS58. Wack0(t/c) 15:36, 12 August 2010 (UTC)
Because that thing has all kinds of confusing menus,... This is just a simple application that only installs a sane IOS58 without any changes. It's perfect to link people who have no clue about the Wii to this tool to just install that one required IOS. WiiSCU might make them install some crapIOS even though they don't even need it. --Svpe 15:41, 12 August 2010 (UTC)
Now, there's Wiinstall which is Dop-Mii without the IOS patching or requiring Trucha. --Steveice10 18:35, 24 August 2010 (UTC)

Source code available?

Your comments regarding DOP-Mii sparked my curiosity.--Arikado 22:08, 11 August 2010 (UTC)

How to use USB2.0?

Do i just need to IOS_ReloadIOS(58) to get USB2.0 speed, or i have to do some more initialization of USB? Is there patches required for libogc? Sorg 06:10, 12 August 2010 (UTC)

There was a huge change in libogc to automatically use USB2.0. But you'll have to compile libogc from svn--Attila 10:20, 12 August 2010 (UTC)
Thanks for info! I've compiled latest libogc SVN. looks like IOS58 doesn't support USB keyboard. I don't know if it because of IOS58 itself or some bug in libogc. But with IOS36 USB keyboard works (the same libogc version) Sorg 21:51, 12 August 2010 (UTC)
It should work. Are you reloading to IOS58, then doing the Keyboard init? You could also try adding a usleep delay in between to be sure IOS is ready... --Tantric 00:48, 13 August 2010 (UTC)
There are 2 USB devices connected to my Wii: Nintendo USB LAN and Wireless USB keyboard. USB LAN works fine with IOS58, while Keyboard doesn't (either together with USB LAN or only keyboard). I will check more configs like old libogc... Sorg 04:56, 13 August 2010 (UTC)
Well, with both old (latest released 1.8.3 iirc) and new svn libogc with IOS58 don't work with keyboard. To clear up things, i've just compiled libwiikeyboard test sample on page: http://wiibrew.org/wiki/Libwiikeyboard. If i add IOS_ReloadIOS(58); sleep(1); then kebaord doesn't work. Try yourself and see... Sorg 05:23, 13 August 2010 (UTC)
Paste the code on pastie.org. --Tantric 05:27, 13 August 2010 (UTC)
http://pastie.org/1089960 Sorg 07:37, 13 August 2010 (UTC)
didn't try your code, but keyboard works just fine here with IOS58 dhewg 10:31, 13 August 2010 (UTC)
I found bug in SNEEK. That was causing problem with IOS58. Sorg 10:21, 14 August 2010 (UTC)

More informations

This is interesting news. What makes IOS58 different from other IOS (i.e why was is not possible before) ? Are USB2 driver implemented in IOS or in the upcoming libogc ? Eke 07:43, 12 August 2010 (UTC)

IOS58 has USB 2.0 support. Only IOS which has it officially. --SifJar 09:27, 12 August 2010 (UTC)

HBC v1.0.8 isn't needed to run installer

The main page needs to be edited. Any non-stub IOS, patched or unpatched, can install a vanilla IOS. <no_ios_reload> is unnecessary in the meta.xml file, since you can run this app without ahbprot; even if it was necessary, you could use it from v1.0.7 as well. You still need to (re)install HBC v1.0.8 after installing IOS58 since it is the only release (as of now) that supports IOS58, but you don't have to have the latest version to begin with. You should even be able to run this without the HBC all together if you use an exploit, forwarder channel, or some other kind of app loader.

Out of respect for the author, I'll wait awhile and see if Tantric either edits the main page or responds to this post, but if it is ignored I will need to change it so users can avoid unnecessary steps.--JoostinOnline 21:04, 28 June 2011 (CEST)

I can only assume blindly here, but my guess is that 1.0.8 is the only homebrew loader that this has been tested with. While in theory, there should be absolutely no reason for a different experience with another environment, some developers prefer to recommend only tried and tested environments, which are known to work perfectly, to avoid potential errors arising from external factors. As I say, just a guess. --SifJar 23:06, 28 June 2011 (CEST)
JoostinOnline is right, HBC 1.0.8 (or AHBPROT) isn't required for the installation. I've made the changes. --Tantric 02:25, 30 June 2011 (CEST)
Thanks. This is such a great app, especially because it is so simple to use, and a billion times safer than telling newbies to use something like Dop-Mii. Don't want to discourage it's use by adding things that aren't required, you know? --JoostinOnline 17:19, 30 June 2011 (CEST)
Personal tools
Resources
Community