From WiiBrew
Jump to navigation Jump to search

IP stuff

I am connecting to the IP address, BUT when "Listening on TCP port 80..." appears, it just gets stuck there and doesn't move on at all, even after waiting for 30 minutes. Also, whenever I try to go to the site that you gave me on my computer, it always says "Page cannot be displayed". I do have a DSL connection and a Wii USB Wi-Fi connector with my Wii allowed to connect to it.SF49 14:56 2 July 2008 (CEST)

Yea this also is happening to me, everything seems to be working for me except web servers. michael5098

The same thing was happening to me. I had to use a different version then what's on this site. Milas60 does your isp allow servers on their connection? Calthephenom 23:47, 12 August 2009 (UTC)

Im new to this

So where do I put the http files?

On your SD card, create a directory called "www" and place any files you would like to be served in there. --Teknecal 00:10, 31 August 2008 (UTC)

Ultiimate Server

Can the both teams of FTPii and Wiihttpd (or somebody else) release a FTP+HTTP server in one app ? It will be very cool to create the ultiimate server (if it is techncally possible) ;-)

orksovaj 13:21, 31 August 2008 (UTC)

Change port

I need the server to operate on a port other than 80 (Many isp's block this port) Compiling the source hasn't gone that well so far, i'm getting stuck with various build errors.

What kind of errors are you having and which port would be suitable for you? --Teknecal 09:06, 8 December 2008 (UTC)

Got it working on 6873, false alarm


I just realized that the fan doesn't run during a dump using Wiihttpd. The estimated time of the dump is around 8 hrs. That sounds like a huge time gap to not have the fan on. I'll look into code for switching the fan on, but I just wanted to let you know. Tell me if that might be something simple to switch on to ensure the life of my Wii.

Error accepting connection


I'm using homebrew channel to load Wiihttpd, but got the message "This is no valid Wii application". So I converted the boot.elf to a boot.dol file (using this) and tried again. Now i'm getting this:

Network initialised. Wii IP address: Listening on TCP port 80... Error accepting connection: Error accepting connection: Error accepting connection: Error accepting connection: .........

with no more information whatsoever. Internet works ofcourse outside wiihttpd.

What now?

That's a bit strange. I assume you receive those messages when trying to connect to your Wii's IP? Can you try out ftpii and see if that works? --Teknecal 05:39, 30 December 2008 (UTC)

--> I'm getting the exact same results as the original poster. Yes, the "Error accepting connection:" messages appear on the Wii once you start to connect to it via the PC. When you stop trying to connect, the messages continue to repeat every few seconds.

I tried using ftpii and I get "Listening on TCP port 21..." on the Wii. When I try to connect to it from a DOS prompt I get the message "Connected to x.x.x.x." but no command prompt, no user name or password request and then after about 10 seconds it times-out and I get "Connection closed by remote host." The Wii screen remains at the "Listening..." message and nothing changes on the Wii screen.

Any ideas? -- Penguin64

--> New Update: I was getting the issue above with the wiihttpd Server ISO Dumper version. I tried the same thing (convert the *.elf to *.dol) with the regular wiihttpd server and got a different result. This time once it said "Listening on TCP port 80..." it stayed like that and I lost connection to my Wii (could not even ping it). I rebooted and tried the regualar wiihttpd server again and this time it worked as expected... I got a 404 error as served up by the wiihttpd. So for fun, I tried the ISO Dumper version again and IT WORKED! My only explanation is that the regular version installed/changed something to allow the ISO Dumper version to work.

I hope that helps someone. -- Penguin64

Error initializing fat subsystem


I'm using Homebrew Channel v1.0.1 to load Wiihttpd, everything looks fine but the an error line appears: Error initializing fat subsystem...

Anybody know how to resolve this???

Thanks in advance.

Do you have a SDHC memory card? If so, you will need to recompile Wiihttpd with the latest libfat. --Teknecal 08:44, 6 January 2009 (UTC)

I have a similar problem; I get the same error and one saying that it can't initialize root subsystem. Then it brings up a bunch of numbers crashing my wii making me have to unplug it in order for it to work again. I have a WiiKey Fusion mod chip and didn't install a custom IOS.

I will be trying that now. Werl 03:40, 23 August 2011 (CEST)

How to get your files

It appears that this server does not generate .html pages to list files.

This means, that after converting the .elf to .dol and adding your files to the /www directory you'll have to point your browser exactly to the file you want.

For instance if you have added a test.mp3 file and your wii's address is, you'll have to point your browser to

This however, will print the code of that image in your browser. To get it you will need to use a download manager such as FlashGet. The only files that should be opened in the browser are these: *.htm;*.html;*.jpg;*.jpeg;*.gif;*.png;*.txt;*.swf;*.svg

If you have many files and do not want to remember all their names you can generate your own .html listing, before transferring the files to your wii, using a program like File List Generator ( This one doesn't make make links for each file but the listings can help a lot. --MadCatMk2 16:41, 7 July 2009 (UTC)

Having trouble with files

I am having trouble trying to get files in common.h. I am using abcwebwizard to create a website, and the evaulation version just allows you to save them as .www . I used Wii Web Server and changed the ending of the file to .html and it came up with a bunch of code, which is what I was expecting. Is there a special way to add files to common.h? Domstang68 00:13, 11 August 2009 (UTC)Posted by Domstang68

You just need to add a new line in common.h like the below and just insert it after say the {"html", "text/html" line:

{"www", "text/html" },

--Teknecal 12:45, 11 August 2009 (UTC)

I did that, and it still came up all code. It might not read it right. I did exactly as that and it came up, but nothing like what I saw. It was all symbols. Maybe you could use abcwebwizard evaulation and tell me if it works. I plan to use kompozer as this may not work. --Domstang68 11:22 PM August 11 2009 (ET) —Preceding unsigned comment added by Domstang68 (talkcontribs) 03:22, 12 August 2009 (UTC)

I have just tested that software, the .www file is actually just the project file associated with that application (only that application can read it properly). What you need to do is upload the files via FTP from the file menu option (I suggest using ftpii and transfer them to your Wii's SD card). --Teknecal 04:23, 12 August 2009 (UTC)

I did exactly as you said. I typed in This was the only one that worked. Unfortunately, I got just the text and bottom hyperlinks. As I was downloading the page, an excpetion occured qlong with a code dump. I just don't get it. I put the files through ftpii and got them on the card properly. I got 1 hyperlink the second time I tried. I am using v0.0.1 from the Homebrew /browser. Plus, I tried v0.0.2 and it didn't work. First it didn't show up at all, then I put the boot in the main wiihttpd and it wasn't a valid application.

Domstang68 22:20, 12 August 2009 (UTC)Domstang68


is there support for php,aka will php be executed by the browser or will it be shown as text --Calthephenom 23:46, 12 August 2009 (UTC)

Get it to work

I'm new to this application, and I'm wondering how to back up Wii/Gamecube games with this (as the page displays a 404 error). Do you add some special HTML page to the SD card? I am completely confused. Please help!! --d4M 12:37, 9 January 2010 (UTC)