Talk:FCE Ultra GX/Archive 2

From WiiBrew
Jump to navigation Jump to search

Bug Reports

Zapper Support (Fixed: 2.0.2)

Doesn't it make more sense to use B to shoot (instead of A) so that you can use the Wii Zapper peripheral and also to make it more like the original NES zapper, trigger on bottom? Deozaan 23:46, 9 September 2008 (UTC)

Tantric have corrected this for the next version (2.0.2), in the next you can use A or B - Yod4z GMT+1 09:31
Glad to hear it's been fixed. I was going to mention this as well. I look forward to the new version. Nago 04:58, 17 September 2008 (UTC) (PS: I wonder if there's a way to get running mat support...?)

It wont startup (Fixed: 2.0.2)

I downloaded the new ver 2.0.0 of the FCE Ultra GX and when I try to startup the emulator I get the normal background with the text "initializing network" or something along the lines of that and it never does anything thing beyond this. Chosen One 41 06:33, 7 September 2008 (UTC)

Can you try disabling the wifi ou LAN connexion of your Wii? Where are stored your ROMs? - Yod4z 15:10 GMT+1
I put it in fceugx\roms and I did try disabling the Wifi connection but it didn't work. I also got the new 2.0.1 version now. --Chosen One 41 02:02, 10 September 2008 (UTC)
Same issue here. 512Mb SD card, roms in fceugx\roms, launching from Homebrew Channel. Going to try to disable wifi connection. Thav 01:04, 12 September 2008 (UTC)
Update: I just let it sit for a while (~20 minutes) at the "Initializing Network" screen. When I came back it said "Preferences reset, hit A to continue". Now it's working fine. Thav 01:31, 12 September 2008 (UTC)
Aye, could somebody post the "default" FCEUGX.xml so people could start the emulator for the first time without having to go through a huge wait as it builds/resets the settings?--Solcott 18:21, 13 September 2008 (UTC)
Update: I just posted the default config file now.--Solcott 18:42, 13 September 2008 (UTC)
I've had the same issue. Default install from HBC, loading from SD. Works after the network init times out(?), but perhaps the next version could include a more sane default for first-run?

Savestates borked? (Fixed 2.0.2)

Savestates broken? it seems as though the regular battery method of saving works as far as I can tell, but with a "default" install and loading from the front SD slot, I am unable to create savestates. What's up? Nago 05:18, 17 September 2008 (UTC)

Some rom names not showing up (Fixed)

Loaded a rom list from SD, though some names didn't show up, in particular: "Super Mario Bros. + Duck Hunt + World Class Track Meet (U).nes" I'm not sure if it's the length of the name or the +s that made it not show up, but it didn't show up in the list until I renamed it "supmar - duckhunt - trackmeet.nes" instead. Nago 05:19, 17 September 2008 (UTC)

Edit: they do show up. "Super Mario Bros. + Duck Hunt + World Class Track Meet (U).nes" shows up as "Super Mario Bros" (no period.) although "Super Mario Bros. 2 (U) (PRG0) [!].nes" shows up just fine. Probably a bad method used for stripping the file extension. Nago 04:35, 21 September 2008 (UTC)
I guess this is the problem: .

Crackling Sound Issue (Fixed: 2.0.6)

Just for sake of completeness, I'm adding this report. Apparently, games have sound that load fine at first (A good reference is Super Mario Bros.), but after so many seconds of play, the sound becomes scratchy and/or crackly. Going to the main menu and resuming play is enough to get the sound working properly for another minute or so. Does anyone have additional symptops or diagnostics to offer? --Nago 22:18, 2 October 2008 (UTC)

I can agree that I am having the exact same problem even with version 2.0.4. While the audio quality is overall quite good, it almost seems as if the sound filters just die off after about 1-2 minutes of gameplay, making the audio very scratchy/crackly and rather disturbing to the ears. As previously stated, returning to the menu will grant another minute or two of filtered audio, but it still dies out. --Turndawg107 6:55, 16 October 2008 (UTC)

Tantric has stated that he will not be attempting to fix this bug, though if anyone comes up with a fix, he will happily add the patch. If anyone has any additional diagnostics or hints as to where to start looking, this would be a great place to share. --Nago 18:14, 17 October 2008 (UTC)

And not even a week later a fix has been implemented. Outstanding job, guys. --Nago 19:23, 20 October 2008 (UTC)

Feature Requests

7zip support? (Implemented 2.0.4)

I see you are using some part of 7zip code to decode zip file, can you add support for .7z file in FCEUltra? -Yod4z 15:05 GMT+1

I plan to add 7z support, but the code has to be rewritten and integrated to work with the new code base. This will take a little bit of work and I haven't gotten around to it yet. --Tantric 18:31, 7 September 2008 (UTC)
Thanks ;) I think if you can add this to FCEUltra, you add this to Snes9xGX too.

When are we going to get 4 player support for the nes (Implemented)

I would really like 4 player support if it is possible for the nes. there are a couple of games like world cup and spot that I would like to play with 4 players. If this is possible or you guys are working on it would you let me know. thanks.

What are you talking about? It's called Four Score and there's already an option for that in the emulator. --Tantric 15:19, 15 October 2008 (UTC)

Support for custom palettes? (Rejected)

Only supporting a hard-coded selection of pre-made palettes is pretty limiting; Support for keeping them in sd:/fceugx/palettes would be nice. Thanks!

Load 7z files directly? (Won't Fix)

When loading a 7z, it enters the archive as though it were a directory, unlike zip files. --trefrog 10:30, 6 January 2009 (UTC)

This is by design. The 7z format is a good choice for storing numerous roms, especially different variants of the same game (due to the way it compresses). I wouldn't want someone not knowing which file in the archive is being loaded. Use zip files if you want to load a file directly. --Tantric 17:40, 6 January 2009 (UTC)


Default FCEUGX.xml for FCE Ultra GX 2.0.1

If you run the emulator (2.0.1) for the first time and get stuck at the Initializing Network message create a text file called FCEUGX.xml in 'sdroot/fceugx/saves' and paste this as its contents. This bug was fixed for 2.0.2. --Solcott 18:42, 13 September 2008 (UTC)

<?xml version="1.0"?>
<file version="FCE Ultra GX 2.0.1">

<section name="File" description="File Settings">
	<setting name="AutoLoad" value="1" description="Auto Load" />
	<setting name="AutoSave" value="1" description="Auto Save" />
	<setting name="LoadMethod" value="0" description="Load Method" />
	<setting name="SaveMethod" value="0" description="Save Method" />
	<setting name="LoadFolder" value="fceugx/roms" description="Load Folder" />
	<setting name="SaveFolder" value="fceugx/saves" description="Save Folder" />
	<setting name="CheatFolder" value="fceugx/cheats" description="Cheats Folder" />
	<setting name="VerifySaves" value="0" description="Verify Memory Card Saves" />

<section name="Network" description="Network Settings">
	<setting name="smbip" value="" description="Share Computer IP" />
	<setting name="smbshare" value="NES" description="Share Name" />
	<setting name="smbuser" value="Wiiuser" description="Share Username" />
	<setting name="smbpwd" value="password" description="Share Password" />

<section name="Emulation" description="Emulation Settings">
	<setting name="currpal" value="0" description="Palette" />
	<setting name="timing" value="0" description="Timing" />
	<setting name="slimit" value="1" description="8 Sprite Limit" />
	<setting name="screenscaler" value="2" description="Screen Scaler" />

<section name="Controller" description="Controller Settings">
	<setting name="FSDisable" value="1" description="Four Score" />
	<setting name="zapper" value="0" description="Zapper" />
	<controller name="gcpadmap" description="GameCube Pad">
		<button number="0" assignment="512" />
		<button number="1" assignment="256" />
		<button number="2" assignment="64" />
		<button number="3" assignment="32" />
		<button number="4" assignment="8" />
		<button number="5" assignment="4" />
		<button number="6" assignment="1" />
		<button number="7" assignment="2" />
	<controller name="wmpadmap" description="Wiimote">
		<button number="0" assignment="2" />
		<button number="1" assignment="1" />
		<button number="2" assignment="16" />
		<button number="3" assignment="4096" />
		<button number="4" assignment="512" />
		<button number="5" assignment="256" />
		<button number="6" assignment="2048" />
		<button number="7" assignment="1024" />
	<controller name="ccpadmap" description="Classic Controller">
		<button number="0" assignment="2097152" />
		<button number="1" assignment="4194304" />
		<button number="2" assignment="268435456" />
		<button number="3" assignment="67108864" />
		<button number="4" assignment="65536" />
		<button number="5" assignment="1073741824" />
		<button number="6" assignment="131072" />
		<button number="7" assignment="-2147483648" />
	<controller name="ncpadmap" description="Nunchuk">
		<button number="0" assignment="131072" />
		<button number="1" assignment="65536" />
		<button number="2" assignment="16" />
		<button number="3" assignment="4096" />
		<button number="4" assignment="2048" />
		<button number="5" assignment="1024" />
		<button number="6" assignment="256" />
		<button number="7" assignment="512" />

Can't use SMB (Resolved: Use Wifi for now)

Unable to initialize network. The share computer is XP Pro w/SP3, and has happily served everything I've wanted, across bridges to various machines, until now. I've tried these settings:

name="smbip" value="" // IP of the computer I am sharing the ROMs from

name="smbshare" value="fceugx" // share root folder I am sharing

name="smbuser" value="geexbox"

name="smbpwd" value="geexbox" // I'm borrowing this user/pwd due to laziness, GeexBox used it ok.

...With these server-side folder arrangements, bold being root shares (as it appears to workgroup clients):

R:\Game Roms\NES\USA\ | F:\fceugx\[roms\ & saves\] | F:\fceugx\fceugx\[roms\ & saves\] | F:\fceugx\roms

...correspondingly changing the smbshare value and/or folder share name to match, case and all. Does the folder structure even matter?

The permissions have been set various ways, I've even given full security and share permissions to Everyone, to no avail.

Looked in the source code (GameCube's, for 'fceuconfig.cpp' doesn't exist in the wii branch) to re-check the descriptions, and noticed the settings were written in a different order, though I don't believe that should make any difference. Even tried switching the USB ethernet adapter between ports.

Whaddami Missing? --Zandro 13:07, 20 September 2008 (UTC)

Are you putting the XML file on your SD card, in the fceugx/saves folder? What happens when you change Load Method to Network and the click Load Game? --Tantric 16:08, 20 September 2008 (UTC)
Indeed, I am uploading the modified version of the XML (having maintained UNIX style carriage returns with a compatible editor) to location from which it was originally generated, sd/fceugx/saves. I do have Load Method Network chosen and is being represented in the XML as number 4. Resulting text of repeat attempts to Choose Game are as follows:
1. Initializing Network... Unable to initialize network. 2. Initializing Network... Failed to connect to network share. 3. Failed to connect to network share.
I will now test this with another computer (installed from an identical source CD) that has performed differently whilst testing GeexBox, as to why I have yet to be able to determine. ...Same results. --Zandro 17:21, 20 September 2008 (UTC)
Check if you can load FCEUGX using wiiload with the HBC. I had a problem with consistently connecting to my wireless network with the Wii, it was a result of wireless interference. I changed my broadcast channel on my router to fix this. A good test of this for me was that wiiload worked 100% better after the change. --Tantric 17:42, 20 September 2008 (UTC)
My console is configured to use the USB wired ethernet adapter, so wireless crosstalk interference shouldn't be a consideration. Is there no support for this adapter in your program yet? wiiload didn't help (yet), so I will now try the wireless interface. 18:56 (UTC) ... Aahh, that works, both through wiiload and the apps install! I now have a new bug to report... -Zandro
USB ethernet is not supported yet by libogc, the homebrew development library that FCEU and most homebrew uses. Geexbox uses wiilinux, which is different. When libogc adds support for USB ethernet, it will be available in FCEU.

Static SMB share directory structuring (Resolved: see "File Settings" in XML)

Now, when I access a folder structure such as: smb://fceugx/[roms/ & saves/] ... It 'could not open /fceugx/roms', yet lists both directories as it's supposed to (they're hard-coded entries of what the emulator expects to see?). I then attempt to enter /roms or /saves, and it gives the same message, but with an additional recursion of the /roms or /saves directory within the message. (I'm definitely not explaining this clearly.) It can't open /fceugx/roms/[roms / saves]. I try again, it adds another of what I tried to enter, ad infinitum.

When I traverse backwards to the root again, e.g. to where it no longer shows the [..] dir path, then click on /roms there, it finally lists the rom files correctly, and I can run them. "Ah-hah, this must be the real roms dir."

When I attempt to access smb://fceugx/ with the rom files in this root, with or without roms/saves directories, the roms will be listed after the 'could not open' error, but the roms cannot be loaded -- it only throws the NES color palette.

The best results, and with no errors returned, is when I set up the share directory structure as it is reflected on the SD card, smb://fceugx/fceugx/[roms/ & saves/]. I think this static directory mapping isn't 100% reasonable, and, for I was able to load a rom with a more direct structure (albeit with traversal errors), might not be absolutely necessary if implemented right. *sigh* this is me trying to help :P Thanks~! --Zandro 19:47, 20 September 2008 (UTC)

Wow, you're confusing me. There's no need for smb:// anywhere - that's not how this structure works. Inside your SMB share folder, create fceugx/roms and fceugx/saves. It works fine for me to simply set the XML folders as the standard in the above XML file. <setting name="LoadFolder" value="fceugx/roms" description="Load Folder" /> <setting name="SaveFolder" value="fceugx/saves" description="Save Folder" /> --Tantric 21:51, 20 September 2008 (UTC)
No, you're right... I am not actually typing in smb://, I was just badly stating that I am accessing SMB shares, as opposed to SD cards or USB drives.
Ack, I never saw those LoadFolder or SaveFolder values! That's it, now I can set FCEUGX to use the same folder layout I've had for years. Thanks again! Your informing me of the libogc limitation has corrected more of my misunderstandings. I have no further inquiries, I promise! I'm just throwing out what I assume others might be having trouble with, so that they may learn from my experiences. --Zandro 22:30, 20 September 2008 (UTC)
I'm happy to hear someone's using this feature, and it's good to clear up any misunderstandings anyone else might have. One more thing I should add is you can permanently set these values in fceuconfig.c and compile the source. Then you can even load without an XML file on SD/USB - you can even use this directly from network using wiiload without SD/USB required. --Tantric 22:56, 20 September 2008 (UTC)

Directories and logistics for DVD

What directory is used for DVD roms: fceugx/roms or just root directory? It's not listed on the page. Also, how does saving work? Can you specify different media to save data, i.e. read ROMs from DVD but save to SD? Aznstorm 02:33, 21 September 2008 (UTC)

The directory used is determined by the "LoadFolder" and "SaveFolder" values in the "File Settings" section of the XML file. Maybe you can blank out ("") LoadFolder out to define root?
Load Method and Save Method are independently configurable through the Preferences menu. Highlight an option and press A to cycle through the possible storage devices. The folders it will attempt to use on the chosen device is described by the entries of the XML I just mentioned. In your case, I would change Load Method to Network DVD, and Save Method to SD, and the manually specified XML values would be "" and "fceugx/saves". Hope that helps, --Zandro 09:59, 21 September 2008 (UTC)
The information above isn't quite right or clear. By default fceugx/roms is used. If it's not found, it will open the root of your DVD. So there's no need to blank out the LoadFolder. You can indeed load from DVD and save to SD. Just put in your SD card, open the program, set your load method as DVD and save method as SD. Then hit Save Preferences. From now on, it will look on your DVD when you go to Choose Game. --Tantric 16:03, 21 September 2008 (UTC)
I'm sorry, it was a long day. Corrected. =.= When a folder is not found, it shows an error. Will it continue to show the error every time one enters the ROM chooser, until it is corrected in the XML? -Zandro

What's the point in using a DVD when you can fit every NES Rom in less than 512MB? Can you use a CD instead? Deozaan 20:59, 26 September 2008 (UTC)

The Wii will never be able to load cds. I think you can use one DVD for more emulators. Like putting all your SNES and NES roms on one DVD. (That would fit nicely) SanderEvers 08:06, 20 October 2008 (UTC)


UNIF and VS are the same, no? "UNIF" mean "VS. UniSystem" and "VS" mean "VS. DualSystem"? -Yod4z 2 october 2008 12:44 GMT+1

UNIF (Universal NES Image Format) doesn't exactly pertain to a specific type of hardware, such as the Vs. Series. It is more a specification used to describe/emulate any NES cartridge chipset in a rom dump, rather than having to just slap on mapper numbers. Well, I think it is something like that... Here is REV 7b of the open specification, if it helps: Tantric has likely well read-up on the format by now, so he might offer a cleaner explanation than I could in 10 minutes' time. ;) --Zandro 18:31, 2 October 2008 (UTC)