Talk:Accessing Wii Shop Channel from PC

From WiiBrew
Jump to navigation Jump to search

Works for me.

Reason the first page appears blank?

Here's a possible reason the first link ( appears blank might be that the javascript in the page probably doesn't work. It probably can't find important variables like, r.region, r.userAge, and r.language. Without those the page does nothing.

The URLs to shop are probably wrong written. there is "(R)" character, where I think should be "&reg" string. Can you confirm that? Apparently, the page shouws only "????" to me, in either way. Firefox

That's because "&reg" is code for the (R) character. 12:13, 17 February 2008 (PST)

Extra Stuff

  • B_05.jsp details page
  • B_06.jpg more details page
  • B_06_1.jpg content frame for more details page

List of titleId's for VC Releases (North America)

System Title titleId
GEN Altered Beast 000100014D414145
GEN Columns 000100014D414245
GEN Dr. Robotnik's Mean Bean Machine 000100014D414345
GEN Ecco The Dolphin 000100014D414445
GEN Golden Axe 000100014D414545
GEN Gunstar Heroes 000100014D414645
GEN Ristar 000100014D414745
GEN Sonic The Hedgehog 000100014D414845
GEN Space Harrier II 000100014D414945
GEN ToeJam & Earl 000100014D414A45
GEN Bonanza Bros. 000100014D414C45
GEN Comix Zone 000100014D415045
GEN Gain Ground 000100014d414e45
N64 Super Mario 64 000100014E414145
N64 Mario Kart 64 000100014E414245
NES Baseball 0001000146414C45
NES Donkey Kong 0001000146414145
NES Donkey Kong Jr. 0001000146414245
NES Gradius 0001000146415245
NES Ice Hockey 0001000146414A45
NES Mario Bros. 0001000146414645
NES Pinball 0001000146414345
NES Soccer 0001000146414945
NES Solomons Key 0001000146414F45
NES Super Mario Bros. 0001000146414745
NES Tennis 0001000146414845
NES The Legend of Zelda 0001000146414B45
NES Urban Champion 0001000146414E45
NES Warios Woods 0001000146414D45
NES Xevious 0001000146415345
SNES F-Zero 000100014A414345
SNES R-Type III: The Third Lightning 000100014A414845
SNES Sim City 000100014A414645
SNES Street Fighter II: The World Warrior 000100014A414A45
SNES Super Castlevania IV 000100014A414945
SNES The Legend Of Zelda: A Link To The Past 000100014A414445
SNES Contra III: The Alien Wars 000100014A414C45
SNES Super Mario World 000100014A414145
TG16 Alien Crush 0001000150413745
TG16 Bomberman '93 0001000150414145
TG16 Bonks Adventure 0001000150414245
TG16 Dungeon Explorer 0001000150414345
TG16 Military Madness 0001000150414E45
TG16 R-Type 0001000150414445
TG16 Soldier Blade 0001000150414C45
TG16 Super Star Soldier 0001000150414545
TG16 Victory Run 0001000150414645
TG16 Vigilante 0001000150415645

Example URL:

So far I haven't been able to find Moto Roader anywhere. Its the only one I'm missing. Anyone have the titleId for this?

Does it work for other browsers?

I know that there's a way to change your browser agent in other browsers; for example, Internet Explorer 6 can, by editing your registry settings somewhere (I forget the specifics but I did it once on IE). Is it possible to use any browser with a modified user agent to access the Wii Shop Channel, or does it ONLY work properly with Firefox? --Anonymous 21:46, 12 March 2007 (PDT)

Any can be used, as far as I know, just Firefox is the easiest to change the user agent string in. 12:13, 17 February 2008 (PST)
Opera is actually one of the easiest, there's a setting right in the program options dialog. In addition, the Wii actually uses the Opera rendering engine so you'd get the best compatibility from it. -- 21:50, 14 May 2008 (PDT)
Tried to change the user agent of IE7 but that (looks like it) can't be changed Zenuka 01:03, 15 May 2008 (PDT)

Title only shows "F-02"

Has there been a change in the Wii Shop Channel? I used to be able to view it in Firefox, but now I receive a page with 2 dotted lines across it, and in the title it says "F-02". Would the F be Firefox, and have they added detection?

No, probably stands for "forward". View the source of the page, and you'll see why. Bushing 03:54, 20 February 2008 (PST)
Same problem, no idea how to fix it.

I too have only been able to see the two dotted lines, anybody figure out whats wrong yet?

Use "htpps://" instead of just "http://", that fixed it for me. --DKII 19:22, 23 October 2008 (UTC)

Downloaded files

What can we do with downloaded files? I have heard they are encrypted for each consoles.

Doesn't Work on Version 3.5.9

I have Firefox version 3.5.9. It doesn't work because after I follow the directions, when I try to go there, I get a "403 Forbidden" error message when I try going to the URLs. Is this supposed to work on version 3.5.9? Keyboard mouse 02:01, 24 June 2010 (UTC)

The article section "UPDATE (Access Denied)" should explain why you can't get it to work. --Dialexio 02:02, 24 June 2010 (UTC)

No longer working?

I tried, but this doesn't work for me anymore on Firefox and Chrome. It still worked in early 2020. Is it only me? MaksWIIBREW (talk) 21:18, 23 July 2020 (CEST)