Talk:The HOMEbrew Menu Standard Library

From WiiBrew
Jump to navigation Jump to search

Will this also have pointless no homemenu blocks?--henke37 16:41, 9 March 2009 (UTC)

Not entirely sure what you mean by that. If you're asking for the design layout, its one button (logo) at the top of the screen. (Clicking on it will close the menu) 4 buttons in the center (reset, shutdown, return to system menu, return to loader). 5 images at the bottom that indicate which wiimotes are synced and if the balance board is synced.--Arikado

I think what hes asking is if it will have blocks that wont let you return to the home menu at certain times like the real Wii Home button menu. EX: when loading a channel and it has not finished, you cant exit out by using the home button.:) --ChuckBartowski

Well in that case, then no. However, one could add them if they wanted to I suppose.--Arikado 19:28, 17 March 2009 (UTC)

Complaints

An application demonstrating the library has just been released. If you have any complaints or problems, you would do me a huge favor if you would please voice them now before the actual library is released.--Arikado 15:04, 17 March 2009 (UTC)

No hyphen in homebrew, please. --Pinecone 17:13, 17 March 2009 (UTC)
If it is in popular demand, it will be done. If not, even someone with the most basic of image editing skills could easily change it to their liking. To clarify on how compilation is done, the images are compiled with the app (place them in your projects data folder), not with the library (for flexibility).--Arikado 17:58, 17 March 2009 (UTC)
As the idea of this is to be a standard, I would suggest that this is done before initial release. Also, will there be internationalisation? --Pinecone 20:14, 17 March 2009 (UTC)


Tried the demo and it looks awesome. One buggy thing is the wiimote vibration. When you have two wiimotes conected and you go over the buttons with both (Restart, return to loader etc.)the first wiimote starts to freak out and vibrate for a few seconds depending on how long you hold the second wiimote upon a button, while the second doesnt vibrate at all. Sometimes it last 10 seconds or longer of vibration.--ChuckBartowski

I truly thank you for your comments chuck. I was unaware of this bug (having only tested one wiimote and the balance board and having been told the demo worked fine by someone else). I have just borrowed my neighbors wiimote and I can confirm the existance of this bug as well. I almost know for certain what is causing this, and I will fix it and upload a new version of the app this evening (I hope).--Arikado 19:27, 17 March 2009 (UTC)
Its untested, but I've uploaded a new version that should fix the bug in the old version. The problem was a very simple and obvious one. I had merely used the wrong channel for all of the wiimotes except for the first one. You can find the new download link in place of the old one on the wiki page. Thank you again Chuck, that catch of the bug was invaluable to me--Arikado 19:44, 17 March 2009 (UTC)