Talk:DragonMedia Player

From WiiBrew
Jump to: navigation, search

Themes Table

Please don't add your themes to the table unless you actually have a release! Not a place to show off pre-release info! --DragonMinded 19:42, 6 July 2008 (PST)

Apple Hidden Files

I noticed that if you add files from a mac, DMP shows the hidden files (they start with "._") is their anyway that you could hide them. If you accidently play them DMP crashes.

user:sugarfrosted

Switching Music

Upon launching a specific MP3 file (sd://~NAVARR/MUSIC/Vampire_Knight_-_Still_Doll.mp3), a dump is received (file available upon request): Dump: http://img122.imageshack.us/img122/1028/hpim0245wo3.jpg

8000ed28 --> 8000e45c --> 80009f64 --> 8000cc80 -->
80007cfc --> 8000af28 --> 8000b340 --> 80009190 -->
800043a4

v0.3a --Navarr 10:38, 1 July 2008 (CEST)

Probaby will need the mp3. Does it crash right when clicking on it, or after a bit of playing?
--DragonMinded 12:59, 1 July 2008 (PST)
It crashes immediately after clicking it.
--Navarr 01:31, 2 July 2008 (CEST)
Ok well I'll still need the mp3...
--DragonMinded 21:33, 1 July 2008 (PST)
mp3
--Navarr 07:21, 2 July 2008 (CEST)
It's crashing while mpg123 tries to interpret the xing header in the file. I don't know why, but I've contacted them. For now, try a different conversion of it.
--DragonMinded 23:24, 1 July 2008 (PST)

Good to see you back ;)

And sorry for my mess :( --GeekShadow 14:24, 1 July 2008 (CEST)

Large amount of files in directory

When loading a directory with a lot of files in it (247 of them, to be exact), the program crashes. --Xero 20:14, 1 July 2008 (EST)

Changed the way it does directories. Should load this now and should be faster.
--DragonMinded 21:33, 1 July 2008 (PST)

Renaming dmp folder

I finally found why DMP didn't start, I renamed the folder dmp in apps to DragonMedia Player.

Yes, if you rename the directory, it doesn't know how to find the files. Don't rename it.
--DragonMinded 21:33, 1 July 2008 (PST)

BGGraphic?

Are there any restrictions of the BGGraphic-File? I tried a 640x480 .png, without any success.

	<Application>
		<BGColor>1C1C1C</BGColor>
		<BGGraphic>background.png</BGGraphic>
	</Application>

Also, if I delete the BGColor entry, it doesn't change... any suggestions? The file exists of course... Oh, and is there any chance to change the skin at runtime? -- arn` 01:10, 3 July 2008 (GMT+1)

The restriction is I haven't added background support to the whole application yet, so it won't load one ;P Of course runtime skin changing is planned, but there are far more important things to do. It's only been out for a week.
--DragonMinded 16:19, 2 July 2008 (PST)
OK, good Point. ;x
What I've found next is, that "Color" seems to don't work for CurrentLength and CurrentPlayTime (& NowPlaying?). -- arn` 01:22, 3 July 2008 (GMT+1)
Well, new version fixed it, thanks! I've spend some hours making this:
http://img3.imagebanana.com/img/ly5wv8c/0xPREVIEW.png -- arn` 19:51, 3 July 2008 (GMT+1)
Your image host doesn't allow hotlinking...
--DragonMinded 11:06, 3 July 2008 (PST)
It doesn't? O_o Here's another one: http://img387.imageshack.us/my.php?image=0xpreviewla1.png -- arn` 20:13, 3 July 2008 (GMT+1)
Damn that looks good. Keep it polished and it might be a skin that ships default. Any way I could grab the current version?
--DragonMinded 10:42, 4 July 2008 (PST)
Possible. I want to create another one or two before releasing anything. ;) -- arn` 23:57, 5 July 2008 (GMT+1)
Wow, I like that theme a lot. Let me know when you release it, I definitely want that. ^_^ --Thegamefreak0134 17:38, 22 July 2008 (CEST)

Bug Reports

Just add any bug you found, for better overview:

--WhoDares 12:11, 12 August 2008 (CEST) [1]
Version Description Fix
0.05 Alpha Custom theme's cursor .png doesn't get displayed change "<Filename>" to "</FileName>"
0.05 Alpha displacement of elements (buttons etc.) background unless Position is set to '0, 0' in settings.xml fixed in 0.06 Alpha!
0.06 Alpha crashes when "Home" is pressed while theme uses no "Menu" image fixed in 0.07 Alpha!
0.1 Beta Certain .flac files cause slowdown with stuttering audio. "Demon Seed" by Nine Inch Nails is one example. (It's a free download from nin.com if you want to test it).
0.11 Alpha and lower You can not change color of the text in the menu and the menu's button labels
0.11 Alpha and lower fastly switching between tracks crashes DMP 0.13 fixes it
0.12 Alpha Install Dark-Ice theme, switch some times between themes -> crash.
0.12 Alpha Install DMP, fresh installation. Switch to dark theme, back to default and again to dark -> return to loader.
0.15 Alpha Ben Daglish's W.E.M.U.S.I.C. 1 SID crashes the player, but thanks for adding SID! Edit: Sorry, locks it up, not crashes
0.16 Alpha Set it to play random, browsed the sd directory, went back to the music folder, stopped playing when the current song finished (ie didn't load a new one.) I could select a new song and it continued playing fine.
0.16 Alpha The linked file crashes player with CODE DUMP. Screen photo of code dump included in the same archive --Alfsoft 9:12, 16 August 2008 (GMT +3) [2] (133Kb)
I have yet to reproduce the fast track switching crash. There needs to be more description as to how to do this.
--DragonMinded 08:23, 22 July 2008 (GMT+8)

Oh, and awesome work with the drivelight. -- arn` 08:30, 7 July 2008 (GMT+1)

Cursor gets displayed fine, Filename was renamed to FileName for consistency
--DragonMinded 07:20, 7 July 2008 (GMT+8)


I hope it helps you, DragonMinded. And one question, is there a way to get out of the "Home-Menu"? -- arn` 18:05, 8 July 2008 (GMT+1)

Hey, when I'm changing files up and down quickly while listening to a song, I get the "dump code" or whatever it's called. Just letting you know. SL92 18:05, 8 July 2008 (GMT-3:30)

Same code 0.16 DSI exception error dump as Alfsoft. I noticed in the last HBB update that the config file was set to theme Xbmc. I had never downloaded that theme. No problems now since I installed that theme, didn't bother to edit the config CarstenK 05:12, 18 August 2008 (UTC)

Burn in protection

Is it possible to add a dim screen (after timeout > 15min) or so OR an option/button to render the current spectrum analyser/visualization over the entire screen area? Its for those of us with cheap widescreen LCD TVs affraid of burn in. Its been ages since I coded anything but lately I'm very tempted to rip the source code apart and see what goodies I can add. --Llvanden 11:56, 16 July 2008 (CEST)

LCDs will never get burned in. --Blooper4912 23:50, 16 July 2008 (CEST)
Oh... I somehow think that had something to do with me not getting plasma instead, Still, a full screen visualization would be... novel. Although it looks like I might just be able to modify the theme file to do this? --Llvanden 10:01, 17 July 2008 (CEST)
Interesting, I've seen LCD monitors with burn-in, why not TV's? WhoDares

WhoDares you are incorrect only phosphor based electronics get burn-in meaning only tube TVs and monitors, hence why they invented screensavers, so it is therefore impossible to get burn-in on an LCD television. It may look like one on an LCD screen but is temporary

Ideas

First, I was wondering if you could do something to scroll down and up. I think I saw some arrows for that but they don't seem to work. That would ben ice.

Second, it's been one day that it's released but for future you could implement DVD use with Waninkoko's Custom IOS so we could burn music and listen them in the wii. --LaPatateInc 16 July 2008 (GMT-5)

You can already scroll up and down. Just use the trigger with the pointer on the playlist (like in the opera browser)
And yeah, maybe the usb code from MplayerWii could be used for flash drive reading?--Llvanden 20:11, 16 July 2008 (CEST)
The usb code from MplayerWii is just the libfat patches (however, calling mplayerwii open source is a bit liberal, he includes a bunch of .o files and then the wrapper code to translate mplayer to wii). I've already integrated them, but they do not work for ANY of my drives.
DragonMinded 11:50, 17 July 2008 (GMT+8)
Thanks for the info and Great work! I have just tested 0.11 Alpha with a 4GB Trancend flash drive and it works! There are a few mp3s that stutter. The first mp3 that did this is a 57 minute mp3. At first I thought it was because it was too long and eating up all of the memory. Then I loaded a 3 minute mp3 and it worked great, but then I loaded another 3 minute mp3 and it stuttered. THEN I loaded a 119 minute mp3 and it played great?? I suspect it has something to do with the way the files were encoded and I will try to get more info on the files themselves (bitrates/vbr/cbr etc) if it will help. When this stuttering happens DMP goes visibly slower and the pointer movement goes laggy and jerky itself. The stuttering itself sounds similar to an emulator on a slow CPU or with too short an audio buffer. Hope it helps. Thanks again --Llvanden 11:40, 20 July 2008 (CEST)
The stuttering mp3s are 320kbps CBR joint stereo and one of them is 256 kbps 2 channel stereo. They work flawlessly from the SD card. I assume higher bitrates read more data more frequently as well as 2 channel stereo as apposed to joint stereo? And since the wii USB code is still experimental (and slow) I assume the stuttering is caused by not being able to load faster from USB (yet). Sorry for the frequent posting, but I hope this prevents from people asking you the same thing over and over. --Llvanden 12:54, 20 July 2008 (CEST)
Regarding the stuttering MP3s through USB, I have a small hifi system (LG LF7350) that also plays through USB. Not only does it stutter in a similar manner, but the exact same MP3 files. Though this info might be interesting. --AlbinoV
As for Waninkoko's Custom IOS, Somehow I get the feeling this has something to do with the exploit Busing also discovered and reported to Nintendo. I think this will get fixed with the next firmware update because this same IOS allows an unmodded wii to run illegally copied games. --Llvanden 13:00, 20 July 2008 (CEST)
Absolutly not. The custom IOS is used for homebrew ONLY, they don't want to do a backup loader, they even want to block it. For now I think only a Genesis emulator is able to run roms on a burned dvd, but I think you could read real/burned cds with the mediaplayer. By the way, the exploit Bushing found is for Backups, and he intend not to release it. --LaPatateInc 11:26, 27 July 2008 (GMT-5)


If you are going to make translations for diffrent language, i can help you with finnish translation ;)

--Quu 13:02, 30 July 2008 (GMT+2)

Disable the Wii Light

I was using your player (don't remember which version) and I was able to disable the little wii light...But with the .11 release I can no longer do so. Can you mabey put it back again. --LOLDSFAN 18:35, 19 July 2008 (GMT-08)

This is an option in .11 as well. Nothing changed.
--DragonMinded 12:50, 20 July 2008 (PST)
How do I disable it; when I push the home button it just brings me to the Homebrew Channel? --LOLDSFAN 15:52, 20 July 2008 (GMT-08)

Where's the home menu?

Where is the Home menu in the version 0.11a, when I push the home button I was send to the HBC.

Other issue is that when I push up in the Dpad for the random opcion I gat a cod dump.

You have an incorrect install. Proper skins will show this and work properly.
--DragonMinded 12:50, 20 July 2008 (PST)

It seems that Updating the program using the Homebrew Browser is somehow giving us an incorrect install. I suspect that the skin format changed and the homebrew browser didn't catch this, but that's a total guess in the blue. In any case, my install crashes (Code Dump) in several places, including the Home Button, the Up Key, and playing certain files. I'm going to try a fresh install and see if that fixes the issues. Nice work though, the Wii Light is a really neat effect. Now it looks like I won't have to use my Wiimote with Vista anymore, if this keeps going at this rate. ^_^ ------Thegamefreak0134 08:11, 21 July 2008 (CEST)

Go ahead and redownload the binary zip.
--DragonMinded 12:44, 22 July 2008 (PST)


Same problem for me:

Home Button -> Exit to loader, Up Button -> Core Dump (see http://jens.nightmarestudio.de/wii/dmp-coredump.png), the same with an installation through the Homebrew Broser or a fresh installation. (I have a PAL-Wii running in 576i mode)

But still the dmp is great software, I am currently using it as my default media player :) Just missing better USB-Device support (would it be possible to cache the files to ram/sd?) and FTP-access (or similar) to play music from my NAS.

--Jens-nms 01:30, 22 July 2008 (CEST)

Hmmm...lol that's what I was talking about too... I downloaded mine with the Homebrew Browser too ^_^. --LOLDSFAN 21:56, 21 July 2008 (GMT-08)

...so, don't use the homebrew browser? I don't think it is a bug report when a third party puts an incorrect install out...
--DragonMinded 8:24, 22 July 2008 (PST)
As I said, i downloaded the version from wiibrew, deleted the old version from the sd-card (via HBB) and installed the fresh one -> same problem.
But hey, everything is ok now, I just formatted a new sd-card and everything works as it should :) (corrupted file system, or whatever...)
After some testing: with two sd-cards: On SD-1 everything works perfect (but it's just a 32mb-card, not perfect for a music player), on SD-2, my primary sd-card (2GB) i can't get it work correctly - reformatting, changing partition settings, redownloading the app, nothing works... Do you need some screenshots?
Thanks, main-menu and up-button are fixed with 0.12, and the buffering is doing a much better job for all files tested compared with the previous version (its still stuttering, but just once in 2-3 seconds).
--Jens-nms 01:44, 27 July 2008 (CEST)
Well of course not. This way, at least you know you can ignore such errors, and have a happier time about things. --Thegamefreak0134 17:38, 22 July 2008 (CEST)

Default Theme Buggy (v 0.11a)

I downloaded and tested the direct link from the homebrew apps page, and had crashing issues with the player. Namely, when I pressed [Up] to switch to random play, it crashed with a codedump.

I had to do two things to fix this. First, I installed a custom theme (Dark-Ice, to be exact) and then I went into settings.xml and changed the name of the theme to "default" (it was set to "dark" and failing, causing it to load the images used when no themes are present.) Doing this caused the new theme to load, after which the random play function worked. I think the issue is that there is no image associated with random in the "backup" theme, as I'll call it.

I just figured I'd point this out, as I think its the source of most of the crash bugs, and I know the themes are still being worked on pretty heavily. --Thegamefreak0134 18:55, 22 July 2008 (CEST)

  • EDIT* This also causes the home menu to work, where it was exiting the player immediately before. --Thegamefreak0134 18:57, 22 July 2008 (CEST)
Ok that makes sense, I'll fix the zip file.
--DragonMinded 12:40, 22 July 2008 (GMT+8)

Theme Selection... (how do I put this?...) "Wonky"

When selecting the themes in the home menu, the menu doesn't always show all of the selectable themes. By clicking around, you can make certain themes show up, and certain themes disappear. Its neat, but I don't think its intended, as there doesn't seem to be any logic behind which themes are shown.

This is on a fresh install of version 0.12. I cleared the old dmp folder and copied over, so the three themes in the dmp/themes directory are "default", "dark", and "safe". This is what happens on the home menu:

Select safe: default and dark both shown Select default: Only safe is shown Select safe: default and dark are shown again Select dark: only safe is shown

...OK, Now that I look at that, I can see the logic behind it. So in order to attempt to load a new theme, you must first select the "safe" theme? Thats what seems to be happening, and I won't question the motives behind it, but I guess this serves as kind of a "heads up" for others with this issue. It just looks really strange with a small number of themes.

It lets you select the next and previous theme, by telling you what the name is...
--DragonMinded 8:59, 23 July 2008 (PST)

On a completely related note, what is the samplerate you are mixing the audio out to? I'm getting some quality issues on a few of my MP3 files that I can't hear when playing the same files on my computer (through the same speakers and everything, I can hook either one up to my stereo which is rather nice.) I can only hear this difference with MP3 files so far, I'll try it with some other formats if I can get high quality recordings for them. Of course, I'm also not sure if this is a limitation on the Wii itself, although it doesn't seem like it would be that way.

Oh, and Great Work. This just became my primary MP3 player for Wii (which I'll use a lot) because its the only one of the bunch thats really stable. ^_^ --Thegamefreak0134 09:03, 23 July 2008 (CEST)

Bass/Treble/Midrange

I hate to feature request, but are there any plans for an equaliser or any type of bass/treble/midrange control? The reason I ask is because my MP3s sound like they distort sometimes. I use the same soundsystem on my PC too, except that is running an SB X-Fi which is probably why it sounds better on it :) --Llvanden 15:34, 23 July 2008 (CEST)

Good job :)

Hey DragonMinded. I just want to thank you for your great work on your "DragonMedia Player". I'm a great fan of DMP and use it nearly every day to listen to my music on the Wii. The second thning i want to thank you for is that you included Dark-Ice in the themes directory as a default theme. :) :)

Sorry for my bad english ^^ --DasBaUm 17:18, 23 July 2008 (CEST)

Memleak when Playing Many Songs

52. You can play 52 songs until DMP crashes with a code dump.

I tested this multiple times by going through my playlist, starting with the first song in the list. I get to song number 52 (lethal-lava-land from sm64, an mp3, to be exact) and it crashes when I attempt to load the song. This is a consistent thing. It doesn't crash on that song or the next song or any song after that if I start there. So it seems that no matter what the mode, it crashes with a code dump after around 50 songs have loaded. This is consistent whether I'm playing the songs all the way through or just loading and playing the intros, like when scrolling through the list.

It seems like you have a memleak in the routine that loads a song to play. It doesn't appear to be affected by how much I have scrolled through the list manually (without playing) or how much navigation I do in the filesystem.

I tested this loading songs through the USB drive as well, and it crashes consistently at 50 songs. Seems like this is the source of a number of other crash bugs. ^_^ --Thegamefreak0134 21:20, 23 July 2008 (CEST)

This appears to have been fixed with version 0.13a. I've had my Wii running DMP for about 8 hours straight now from the SD card, and no crashes or anything. ^_^ --Thegamefreak0134 17:49, 1 August 2008 (CEST)

Can't load DMP, hangs on black screen

DMP doesn't load when I have the USB Ethernet adapter on my Wii, but does load without it. Is there a fix or am I doing something wrong? --DarkChili 14:11, 23 July 2008 (PST)

Same here with USB keyboard... --Elgamblo 08:03, 24 July 2008 (CEST)

Might be because DragonMedia Player tries to load an USB-Device to load music files from. So it tries to use the default USB Mass storage device driver for your USB devices. As you can imagine the driver isn't compatible to your deices. I think DragonMinded will fix this problem soon :) --DasBaUm 10:11, 24 July 2008 (CEST)

Blank screen when starting version 0.11 or 0.12

Everytime I try to start version 0.11 or 0.12 i just get a blank screen. Not sure if I installed it wrong. 0.1 beta works fine.

If I recall, version 0.11 added support for USB drives. Because of issues with the USB libraries, this causes the program to crash on startup if you have something that's NOT a USB drive plugged in, examples of which include the Nintento ethernet adapter and a USB keyboard. Removing these devices with a proper install of DMP should fix the black screen on startup, although I would need confirmation to know if that were the case. Just a suggestion. --Thegamefreak0134 07:44, 30 July 2008 (CEST)

Loading pls files leads to Dump

Everytime I try to load a .pls file such as shoutcast files to play it leads right into a dump screen. Am i doing something wrong cause it says that pls files are supported. --Big Bang Theory 23:46 31 July 2008 (CEST)

There is no network/internet support for shoutcasts right now. -- arn`
Thanks thats all I needed to know. --Big Bang Theory 9:46 1 Aug 2008 (CEST)
Could you post any erroring m3u/pls files for me to test. It shouldn't crash on them even if it doesn't support the file sources.
EDIT: Nevermind, fixed anyhow.
--DragonMinded 10:03, 01 August 2008 (PST)

Fails to load with other USB device plugged in

DMP doesn't want to launch when my keyboard and USB stick are both plugged in. Keyboard out, runs just fine.

All around though, AWESOME work! :)

The mplayerwii guy managed to figure out what causes crashes with other devices plugged in. Too bad his source is closed or I could put the fix in...
EDIT: A supposed fix should be in the next release.
--DragonMinded 20:16, 01 August 2008 (PST)

The newest update fixed the problem, thanks! SMR Kurosan 10:23, 9 August 2008 (CEST)

Language Translate

Hello DragonMinded!. I want to thank you for your great work on your "DragonMedia Player"!

i want to offer you my assistance to translate your application to a perfect Spanish, just reply me here, bye!

See you soon --JoeX 14.32:18, 04 August 2008 (GMT - 4)

I will be very interested in translations in the future when I add in the ability to change languages. I post about this when it happens!
--DragonMinded 19:53, 05 August 2008 (PST)
Ok, DMP is now translatable...have at it!
--DragonMinded 13:43, 10 August 2008 (PST)

When that does happen, I would be glad to translate DMP to French, if I may offer my help. SMR Kurosan 07:32, 6 August 2008 (CEST)

yeah :) and i would like to translate it into german ^^ --DasBaUm 09:57, 6 August 2008 (CEST)

EXT2/3 support?

Is it possible to get ext2/3 support? I got 2 usb-hdd's with ext3 filesystem and they are both full of music. It would rock my world if i am able to play mysic from them! --Quu 09:59, 9 Auqust 2008 (GMT+2)


Wiimote LED lightning

It would be veeeeery hot if the Wiimote LEDs would light up with the sound. I am missing this thing since the first release with Wiilight. And, yes, video would be very nice :) Maybe you could steal some code from mplayerwii or something :-D - twofive, 11:39 11.08.2008

Wiimote LED's would be nice! But i think it would drain batteries too much. --Quu 1601, 11 Auq 2008 (GMT+2)

I agree that it would be awesome. Quu: it would drain batteries a little, but if it is made optional then it won't affect those who want to leave it off. OSW 04:12, 18 August 2008 (UTC)

You mean the 4 wiimote leds moving like the on screen spectrum or the drive led? Awesome, and surely to impress friends at a party! Constant wireless activity = definite battery drain tho'. Might be fun anyway. CarstenK 05:18, 18 August 2008 (UTC)

Power Button

It would be wonderful if you could possibly make the power button on the Wii work as normal, but seeing as no one's done it yet, I'm afraid it won't work. it would be nice for the power button on the wii remote to work as well. But if either is not possible, then an on-screen power button would be nice. (I mean, seriously, you can't tell me you haven't checked out the Rebooter!)

We still don't know how the power button on the Wiimote work yet.Felix 10:24, 18 August 2008 (UTC)

Thats not true the home brew channle uses it

No, actually, it doesn't. You might want to sign your additions, especially when you make unverified claims. SMR Kurosan 06:13, 31 August 2008 (UTC)

Ogg file not playing

Hello, greatly enjoying your program so far.

Just one problem I've encountered, this ogg file ( http://www.megaupload.com/?d=29FVUCBD )shows up as -2:11 of -2:11 and will not play under DMP.

I've converted a number of other files in exactly the same manner and they play perfectly. Of course, this file plays alright under other media players.

Also, a suggestion for your consideration. I would greatly appreciate a 'Repeat playback' mode that sequentially plays the current directory but goes back to the first file after playing the last file.

Thanks again.

YM format support source code, just add it ;)

Hi, and congrats for your player.

I just see that you add sc68 support, so you will be perhaps interested in my port of the ym format (stsound from leonard/oxg port). for info you can found the source code play routine in http://wiibrew.org/wiki/Homebrew_apps/ExistenzE

That's all.

Multiple mouse pointers

It would be very cool if you can use multiple mouse pointers. You can connect more two WiiMotes, but you can only use one as controller. Thats bullcrap, so it should be possible to get both of them to work. - twofive, 19-08-08, 12:17

bullcrap? seems like a "bullcrap" feature to support multiple pointers...
--DragonMinded 18:10, 20 August 2008 (PST)

I can't help but wonder what the point of doing that would be. SMR Kurosan 19:19, 19 August 2008 (UTC)

I don't see why not. It's not such an uncommon scenario when someone would want to use the nearest available Wiimote to do something / change a song rather than be bothered to get up and find the original. People are naturally lazy :) AerialX 06:34, 31 August 2008 (UTC)

Implemented Samba support

Hey DragonMinded, DMP is a great player!! I have implemented samba support for the 16alpha version using libtinysmb, maybe you would like to have the code. It's working pretty well now that you have implemented the readahead buffer. I'm also trying to make the program multithreaded to get rid of all the sound.update() calls throughout the code and perhaps fix some sound stuttering problems. - Mtise 14:13, 21 August 2008 (CEST)

I'm already working on samba support myself...
--DragonMinded 12:44, 21 August 2008 (PST)
Do you have any example code for libtinysmb you can share? I can't get it to work as it constantly crashes the Wii. I posted my findings (with source) in a bug report at the devkitpro forums, but perhaps I was doing something wrong.
--DrTwox 21:27, 24 August 2008 (UTC)

WiiMote Speaker MP3

Is it possible to enable the WiiMote Speaker to play mp3? I know the sound quality would be horrible but it would be funny... You implemented a lot of freaky features, why don't implement this then? ;-) - twofive, 22:04 21-08-08

Technically, it would probably be possible, but as you said the sound would be terrible and the Wii Remote batteries would be drained pretty quickly. SMR Kurosan 11:18, 22 August 2008 (UTC)

Yeah that would be kinda cool lol. echoing what the other two have said, but it would still be fun to give it a try OSW 14:26, 22 August 2008 (UTC)

I do not think that this is a good idea considering the poor quality of the wiimote speaker. Sugarfrosted 22:10, 22 August 2008 (UTC-7)

USB scan order?

I'm no programmer, just a very thankful end user. I've come across an issue that could prevent some users from being able to read from their USB thumbdrives/HDDs. If my USB ethernet adapter is plugged into the port closest to the edge of the console, and my thumbdrive (Lexar 1GB formatted as FAT32: http://i34.tinypic.com/205drtj.jpg ) inward, DMP is unable to see the thumbdrive. After they are switched, both will function correctly. I hope this does not turn out to disable wired internet/SMB after it becomes available.

Also, the program froze as I attempted to quit while playing a SIDtune, perpetually replaying ~1/4sec of buffered audio. Being unable to replicate it through various scenarios (formats, tune complexity, menu locations), it may have just been a fluke.

Thanks DragonMinded! --Zandro 06:57, 10 September 2008 (UTC)

This issue has already been mentioned see bugs - sugarfrosted

Thanks sugarfrosted, I did not see your comment until now. My worry of this potentially causing the USB ethernet adapter to not work persists, but I will patiently wait for DM and his muster to work it out, and hopefully see it in the next version :) --Zandro 00:00, 20 September 2008 (UTC)

MP3 bitrate bug on 0.16

Hey there DragonMinded (big fan of your work)! I just wanted to report back on an excellent piece of homebrew. Excellent, but not perfect. I have been experiencing a bug on 0.16 Alpha, in which SOME 112kbps mp3 files show the wrong song length(way too long), as well as elapsed time. The counter for the elapsed time also goes way too fast. In MANY 128kbps, as well as a 123kbps and 126kbps, the problem is the same. I will try to upload a video of it to Youtube. Thanks for an extremely good media player!

I'm not quite sure, but I had a comparable problem on my PC and it became apparent, that this is a problem in the used mp3 files. In detail it was a corrupt Xing Header — caused by a bad/old encoder. -- arn`

Format WMA

In the last realase, can the WMA format be read with DMP ? Scuse for my englesh I'm french... -Safirion 13:17 GMT+1 27 september 2008

No it isn't in the list of supported format maybe in futur release if the autor use some opensource codec for WMA -Yod4z 27 september 2008 15:14 GMT+1
Ok Safirion

I wish this player, could have a restart wii command!!

its a shame this just has return to loader, i was wanting to edit the source to make it restart wii when you cick home, but dragon hasnt included the full source, so i couldnt do it, i need the rest of the binaries of the source. dragonminded please add a restart wii command, or make another link with the restart wii instead of return loader, thanx.

About themes rules

I want to ask if the lenght of seekbar is fixed at 256px, because i'm trying to use a much bigger one for my wmp12 skin for dmp and it does not works. And also i'd like to ask about the multiple of 4 limitation that you have at pngs, to make a proper png (for showing without alignment problems) for buttons like playpause, next and the others you must only make an image which width and height must be multiple of 4 or you must also make sure that the width is also divisible of 3? here are the buttons which i made dmpbuttons -pH0eN1x (CTCaer)

It seems that the multiple of 4 rule if it is not followed the image will not load and dmp will load the default one. -pH0eN1x (CTCaer)

Low quality sound

I have my wii connected to a Hi-fi sound system and I experienced that DMP alpha 16 has low quality in sound.

The mp3 music played with DMP sounds filtered, as it has less bitrate than it actually has. The same mp3 files played with MPlayerWii 0.07 sound much more rich and with full spectral response.

May it be a bug or just a restriction of the implementation source code?

Reboot

As is said before, a reboot option would be nice. For making a channel of it, if you exit then, it crashes, because there isn't a loader to return to. And my knowledge of programming is still low, I don't want to fuck up it.


Hi, Dragon Minded, this isn't the FULL SOURCE, i could easily edit the source so it restarts intead of returning to loader, also could make a shut-down wii command aswell. please upload the full source, as we are missing most of the source, thanx.

This isn't the full source as it cannot compile as its missing plenty of libraries etc.

DragonMinded, why haven't you uploaded the full source. I want to edit the source, many thanx

QUOTE http://flac.sourceforge.net/download.html

that's the site to download libflac I've tried adding that in but get the following errors :\ > "make" flacsource.cpp c:/dmp/source/flacsource.cpp:26: error: 'FLAC__StreamDecoderSeekStatus' does not name a type c:/dmp/source/flacsource.cpp:38: error: 'FLAC__StreamDecoderTellStatus' does not name a type c:/dmp/source/flacsource.cpp:50: error: 'FLAC__StreamDecoderLengthStatus' does not name a type c:/dmp/source/flacsource.cpp: In member function 'virtual OpenStatus FlacSource::openLocation(File*)': c:/dmp/source/flacsource.cpp:227: error: 'FLAC__StreamDecoderInitStatus' was not declared in this scope c:/dmp/source/flacsource.cpp:227: error: expected `;' before 'init' c:/dmp/source/flacsource.cpp:240: error: 'init' was not declared in this scope c:/dmp/source/flacsource.cpp:240: error: 'seek_callback' was not declared in this scope c:/dmp/source/flacsource.cpp:240: error: 'tell_callback' was not declared in this scope c:/dmp/source/flacsource.cpp:240: error: 'length_callback' was not declared in this scope c:/dmp/source/flacsource.cpp:240: error: 'FLAC__stream_decoder_init_ogg_stream' was not declared in this scope c:/dmp/source/flacsource.cpp:245: error: 'init' was not declared in this scope c:/dmp/source/flacsource.cpp:245: error: 'seek_callback' was not declared in this scope c:/dmp/source/flacsource.cpp:245: error: 'tell_callback' was not declared in this scope c:/dmp/source/flacsource.cpp:245: error: 'length_callback' was not declared in this scope c:/dmp/source/flacsource.cpp:245: error: 'FLAC__stream_decoder_init_stream' was not declared in this scope c:/dmp/source/flacsource.cpp:249: error: 'init' was not declared in this scope c:/dmp/source/flacsource.cpp:249: error: 'FLAC__STREAM_DECODER_INIT_STATUS_OK' was not declared in this scope c:/dmp/source/flacsource.cpp: In member function 'virtual void FlacSource::seekSeconds(int)': c:/dmp/source/flacsource.cpp:330: error: 'FLAC__stream_decoder_seek_absolute' was not declared in this scope c:/dmp/source/flacsource.cpp: In member function 'virtual int FlacSource::tellSeconds()': c:/dmp/source/flacsource.cpp:341: error: 'FLAC__stream_decoder_get_decode_position' was not declared in this scope make[1]: *** [flacsource.o] Error 1 "make": *** [build] Error 2

> Process Exit Code: 2 > Time Taken: 00:00


Why wont it compile dragon media player, i have libwiisprite, png & freetype along with DMP source, just cannot compile!! Why even upload a Source code for it, when its not the full source and when you get the required lib files it cannot compile. djdynamtie123 03.11.08

Release

When a new release for DMP ?

French:

Quand est-ce qu'une mise à jour sortira? :'(

320kbps MP3s + USB = laggy playback

I've ran some tests after getting some laggy playback on some of my MP3 files off of my external HDD where I store my music collection. I noticed some of them played perfectly while others were laggy like being streamed form the Internet with a slower connection. Turns out that the MP3s I have with a bitrate of 320kbps are too much for the program to buffer via the USB drive. I've tried my USB flash drive as well getting the same results. However, when playing the same MP3s off of the SD card, I get a flawless playback. Other players I have on my Wii, such as MPlayerWii, can play these high bitrate MP3s off of my external HDD and flash drive without problems so I know the Wii can handle the data rate from the USB ports. If there's any other information that you need from me such as MP3 files I used, please let me know. Oni Kidou 06:04, 14 January 2009 (UTC)

It also affects FLAC playback (impossible from a USB drive) Chupa 12:13, 27 January 2009 (UTC)


request sdhc support

I would love to see SDHC support for DMP as it would alow for my whole music collection to be played on this awesome app

InternetRadio ?

Maybe you can include an Internetradio tool, i think that will be cool ;)

New format

What about USF support? (N64 sound format)--retrotails 23:07, 22 February 2009 (UTC)